summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-08-22 16:27:32 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-08-22 16:32:24 +0200
commit98bdfdbad5275c2ad9dce2e7ec8314ead473d7d5 (patch)
treea392855384924955a00219331aef5d9d0780d4e1
parentapp-misc/openrgb: check for at least 2GB of build space (diff)
downloadgentoo-98bdfdbad5275c2ad9dce2e7ec8314ead473d7d5.tar.gz
gentoo-98bdfdbad5275c2ad9dce2e7ec8314ead473d7d5.tar.bz2
gentoo-98bdfdbad5275c2ad9dce2e7ec8314ead473d7d5.zip
sci-mathematics/opensmt: drop old 2.5.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--sci-mathematics/opensmt/Manifest1
-rw-r--r--sci-mathematics/opensmt/files/opensmt-2.4.3-musl.patch132
-rw-r--r--sci-mathematics/opensmt/opensmt-2.5.1.ebuild72
3 files changed, 0 insertions, 205 deletions
diff --git a/sci-mathematics/opensmt/Manifest b/sci-mathematics/opensmt/Manifest
index b8135a978d7b..efc73de20ff3 100644
--- a/sci-mathematics/opensmt/Manifest
+++ b/sci-mathematics/opensmt/Manifest
@@ -1,2 +1 @@
-DIST opensmt-2.5.1.tar.gz 1943888 BLAKE2B 17b58fc3e693e77ce70835820f7361db9efe1cac561f1fa3480a839fbdf003d2566617cd97a3e2772ad8e890356b6a5761457779c0ac3b0841c2df6aee74946e SHA512 359ff968d7dbd8d94d6c5687d5b84e19c47016df5b1c0d80374743b395b6257cb4b97aa354b264103bd19c522f55912f1c938e646daf37f6b413488db917fc61
DIST opensmt-2.5.2.tar.gz 1935650 BLAKE2B 85cd171d56591d2f1162a41ff8a425fc818238a2820aab0f75cc75ece8898c5e7de1478aeab93e8905a1aedad85a6df03062fefaad69bea043dce1f3f3d531f5 SHA512 c22d17d3aee33a3360f8ea552c82151eafdef7cc89e6750d34b4ff2a011675a5a5f04a7cb68ff984dd6a5332b2f180fb8abc529e64c3970aba6b7eb60408f198
diff --git a/sci-mathematics/opensmt/files/opensmt-2.4.3-musl.patch b/sci-mathematics/opensmt/files/opensmt-2.4.3-musl.patch
deleted file mode 100644
index 5f80a0de116c..000000000000
--- a/sci-mathematics/opensmt/files/opensmt-2.4.3-musl.patch
+++ /dev/null
@@ -1,132 +0,0 @@
-From e88b83b3b52ebc6ff4cdf1f92a876861fc2c5598 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Maciej=20Bar=C4=87?= <xgqt@gentoo.org>
-Date: Mon, 6 Feb 2023 17:27:34 +0100
-Subject: [PATCH] use fpu_control only on glibc
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Signed-off-by: Maciej Barć <xgqt@gentoo.org>
----
- bin/opensmt.C | 4 ++--
- src/bin/opensmt.cc | 2 +-
- src/minisat/core/Main.C | 4 ++--
- src/minisat/simp/Main.C | 4 ++--
- src/minisat/utils/System.h | 2 +-
- src/parallel/opensmtSplitter.cc | 4 ++--
- 6 files changed, 10 insertions(+), 10 deletions(-)
-
-diff --git a/bin/opensmt.C b/bin/opensmt.C
-index cb9c8943b..898a8fdd3 100644
---- a/bin/opensmt.C
-+++ b/bin/opensmt.C
-@@ -44,7 +44,7 @@ WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
- #include <csignal>
- #include <iostream>
-
--#if defined(__linux__)
-+#if defined(__GLIBC__)
- #include <fpu_control.h>
- #endif
-
-@@ -84,7 +84,7 @@ int main( int argc, char * argv[] )
- // the repeatability of experiments that might be compromised
- // by the floating point unit approximations on doubles
- //
--#if defined(__linux__) && !defined( SMTCOMP )
-+#if defined(__GLIBC__) && !defined( SMTCOMP )
- fpu_control_t oldcw, newcw;
- _FPU_GETCW(oldcw); newcw = (oldcw & ~_FPU_EXTENDED) | _FPU_DOUBLE; _FPU_SETCW(newcw);
- #endif
-diff --git a/src/bin/opensmt.cc b/src/bin/opensmt.cc
-index 6db12ffd8..67bfcd712 100644
---- a/src/bin/opensmt.cc
-+++ b/src/bin/opensmt.cc
-@@ -47,7 +47,7 @@ WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
- #endif
- #endif // ENABLE_LINE_EDITING
-
--#if defined(__linux__)
-+#if defined(__GLIBC__)
- #include <fpu_control.h>
- #endif
-
-diff --git a/src/minisat/core/Main.C b/src/minisat/core/Main.C
-index acef32cd5..2c232b71b 100644
---- a/src/minisat/core/Main.C
-+++ b/src/minisat/core/Main.C
-@@ -74,7 +74,7 @@ static inline uint64_t memUsed(void) {
- static inline uint64_t memUsed() { return 0; }
- #endif
-
--#if defined(__linux__)
-+#if defined(__GLIBC__)
- #include <fpu_control.h>
- #endif
-
-@@ -287,7 +287,7 @@ int main(int argc, char** argv)
-
-
- reportf("This is MiniSat 2.0 beta\n");
--#if defined(__linux__)
-+#if defined(__GLIBC__)
- fpu_control_t oldcw, newcw;
- _FPU_GETCW(oldcw); newcw = (oldcw & ~_FPU_EXTENDED) | _FPU_DOUBLE; _FPU_SETCW(newcw);
- reportf("WARNING: for repeatability, setting FPU to use double precision\n");
-diff --git a/src/minisat/simp/Main.C b/src/minisat/simp/Main.C
-index b6d194631..a3f22fb4f 100644
---- a/src/minisat/simp/Main.C
-+++ b/src/minisat/simp/Main.C
-@@ -74,7 +74,7 @@ static inline uint64_t memUsed(void) {
- static inline uint64_t memUsed() { return 0; }
- #endif
-
--#if defined(__linux__)
-+#if defined(__GLIBC__)
- #include <fpu_control.h>
- #endif
-
-@@ -244,7 +244,7 @@ const char* hasPrefix(const char* str, const char* prefix)
- int main(int argc, char** argv)
- {
- reportf("This is MiniSat 2.0 beta\n");
--#if defined(__linux__)
-+#if defined(__GLIBC__)
- fpu_control_t oldcw, newcw;
- _FPU_GETCW(oldcw); newcw = (oldcw & ~_FPU_EXTENDED) | _FPU_DOUBLE; _FPU_SETCW(newcw);
- reportf("WARNING: for repeatability, setting FPU to use double precision\n");
-diff --git a/src/minisat/utils/System.h b/src/minisat/utils/System.h
-index 5f9dc3f53..4b7f9c9f5 100644
---- a/src/minisat/utils/System.h
-+++ b/src/minisat/utils/System.h
-@@ -21,7 +21,7 @@ OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWA
- #ifndef Minisat_System_h
- #define Minisat_System_h
-
--#if defined(__linux__)
-+#if defined(__GLIBC__)
- #include <fpu_control.h>
- #endif
-
-diff --git a/src/parallel/opensmtSplitter.cc b/src/parallel/opensmtSplitter.cc
-index 05246e187..4b8c01a1a 100644
---- a/src/parallel/opensmtSplitter.cc
-+++ b/src/parallel/opensmtSplitter.cc
-@@ -27,7 +27,7 @@
- #endif
- #endif // ENABLE_LINE_EDITING
-
--#if defined(__linux__)
-+#if defined(__GLIBC__)
- #include <fpu_control.h>
- #endif
-
-@@ -55,7 +55,7 @@ int main( int argc, char * argv[] )
- // the repeatability of experiments that might be compromised
- // by the floating point unit approximations on doubles
- //
--#if defined(__linux__)
-+#if defined(__GLIBC__)
- fpu_control_t oldcw, newcw;
- _FPU_GETCW(oldcw); newcw = (oldcw & ~_FPU_EXTENDED) | _FPU_DOUBLE; _FPU_SETCW(newcw);
- #endif
diff --git a/sci-mathematics/opensmt/opensmt-2.5.1.ebuild b/sci-mathematics/opensmt/opensmt-2.5.1.ebuild
deleted file mode 100644
index 04e39c2ae269..000000000000
--- a/sci-mathematics/opensmt/opensmt-2.5.1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Compact and open-source SMT-solver written in C++"
-HOMEPAGE="http://verify.inf.usi.ch/opensmt/
- https://github.com/usi-verification-and-security/opensmt/"
-
-if [[ ${PV} == *9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/usi-verification-and-security/${PN}.git"
-else
- SRC_URI="https://github.com/usi-verification-and-security/${PN}/archive/v${PV}.tar.gz
- -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-IUSE="debug libedit +readline test"
-REQUIRED_USE="?? ( libedit readline )"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/gmp:=[cxx]
- readline? ( sys-libs/readline:= )
- libedit? ( dev-libs/libedit:= )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- sys-devel/bison
- sys-devel/flex
- test? ( dev-cpp/gtest )
-"
-
-# PATCHES=( "${FILESDIR}"/${PN}-2.4.3-musl.patch )
-
-src_prepare() {
- cmake_src_prepare
-
- echo "add_subdirectory(unit)" > "${S}"/test/CMakeLists.txt || die
-}
-
-src_configure() {
- local CMAKE_BUILD_TYPE
- if use debug ; then
- CMAKE_BUILD_TYPE=Debug
- else
- CMAKE_BUILD_TYPE=Release
- fi
-
- local -a mycmakeargs=(
- -DPACKAGE_TESTS=$(usex test)
- -DUSE_READLINE=$(usex readline)
- )
- if use readline || use libedit ; then
- mycmakeargs+=( -DENABLE_LINE_EDITING=ON )
- fi
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- rm "${ED}"/usr/lib/libopensmt.a || die
-
- dolib.so "${ED}"/usr/lib/libopensmt.*
- rm "${ED}"/usr/lib/libopensmt.* || die
-}