summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2021-04-28 09:33:35 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-04-28 10:43:38 +0200
commit98c47fa98315ba70f5e9f9c79f46c0c0fe71d4ec (patch)
treec38b1defd4a5aae573481918a9364db0397bf384
parentdev-tex/tex4ht: Fix bug when hyperref is loaded from a class file (diff)
downloadgentoo-98c47fa9.tar.gz
gentoo-98c47fa9.tar.bz2
gentoo-98c47fa9.zip
dev-java/java-getopt: min java 1.8
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/20568 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--dev-java/java-getopt/java-getopt-1.0.14-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-java/java-getopt/java-getopt-1.0.14-r1.ebuild b/dev-java/java-getopt/java-getopt-1.0.14-r1.ebuild
new file mode 100644
index 000000000000..2cf4dd980a50
--- /dev/null
+++ b/dev-java/java-getopt/java-getopt-1.0.14-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java command line option parser"
+HOMEPAGE="https://www.urbanophile.com/arenn/hacking/download.html"
+SRC_URI="https://www.urbanophile.com/arenn/hacking/getopt/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="1"
+KEYWORDS="amd64 ~arm ~arm64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+ mv gnu/getopt/buildx.xml build.xml || die
+}
+
+src_install() {
+ java-pkg_dojar build/lib/gnu.getopt.jar
+ dodoc gnu/getopt/COPYING.LIB gnu/getopt/ChangeLog gnu/getopt/README
+ use doc && java-pkg_dojavadoc build/api
+ use source && java-pkg_dosrc gnu
+}