summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-02-22 14:44:59 +1300
committerKent Fredric <kentfredric@gmail.com>2016-02-27 21:39:56 +1300
commit98c84198c858853d00060fae42b4968cb1137a70 (patch)
treeabcbb7d9796fb32f89669d7204b80adb73d35583
parentdev-perl/Devel-CheckLib: Added to tree at 1.60.0 (diff)
downloadgentoo-98c84198.tar.gz
gentoo-98c84198.tar.bz2
gentoo-98c84198.zip
dev-perl/Math-GMP: Bump to version 2.110.0
- use EAPI6 - Had to drop keywords on alpha, hppa, mips and ppc due to dev-perl/Devel-CheckLib Package-Manager: portage-2.2.27
-rw-r--r--dev-perl/Math-GMP/Manifest1
-rw-r--r--dev-perl/Math-GMP/Math-GMP-2.110.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Math-GMP/Manifest b/dev-perl/Math-GMP/Manifest
index 3773afe684b6..a9409913bba7 100644
--- a/dev-perl/Math-GMP/Manifest
+++ b/dev-perl/Math-GMP/Manifest
@@ -1 +1,2 @@
DIST Math-GMP-2.06.tar.gz 24563 SHA256 bfd044c51687c7356edba1582f83c34a9dfc0c3451f6faeff400be62a7852b37 SHA512 a2619b76cc89a805e8fb538280644f4acc0c9d3da24b3b0810640c741ff66016c8f4920cd48ef7e6ce0e82bec630c0101d33db22f7928e19a03730b1305cac1e WHIRLPOOL b71418235c811e44f404b84e1a3c95c2be1a60f43d8a5ea2f274f0071a789a76433261cad5704237bcf23b8c81c4c708ff3664b61a9e874d2346d2d898e23330
+DIST Math-GMP-2.11.tar.gz 31178 SHA256 4d535c110bf443638fc2f83da7cb120ea5da91cbf9e3e476584b02c81ac82cda SHA512 4296717691ec7699ba5e82f5c0b3f83a831f8f0006c09a843ef9fc25227a26bdc6a623a728bebfc5df01124747c081239281d1cf861ee73a42444f15848a23d4 WHIRLPOOL 7b08a87ba4c0ad7703b0f8a8166c9f2e0cc5db56e384e531e7b3923c50b873a246b1bebfdca257c63903b65c0b0d525942ca92f21c31fba735474b3542f344b9
diff --git a/dev-perl/Math-GMP/Math-GMP-2.110.0.ebuild b/dev-perl/Math-GMP/Math-GMP-2.110.0.ebuild
new file mode 100644
index 000000000000..a8fd894614c2
--- /dev/null
+++ b/dev-perl/Math-GMP/Math-GMP-2.110.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=SHLOMIF
+DIST_VERSION=2.11
+inherit perl-module
+
+DESCRIPTION="High speed arbitrary size integer math"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-AutoLoader
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ dev-libs/gmp:0
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Devel-CheckLib-0.900.0
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ virtual/perl-IO
+ virtual/perl-Test-Simple
+ )
+"