summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-18 03:35:22 +0000
committerSam James <sam@gentoo.org>2022-12-18 04:01:26 +0000
commit98d1217fd34bc35ff285f57812ade0f517b436b4 (patch)
tree996374ce3c73e6d792fa008d3c929675ac10eebd
parentsci-misc/lttoolbox: add github upstream metadata (diff)
downloadgentoo-98d1217fd34bc35ff285f57812ade0f517b436b4.tar.gz
gentoo-98d1217fd34bc35ff285f57812ade0f517b436b4.tar.bz2
gentoo-98d1217fd34bc35ff285f57812ade0f517b436b4.zip
sci-misc/lttoolbox: add 3.7.1
Closes: https://bugs.gentoo.org/851186 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-misc/lttoolbox/Manifest1
-rw-r--r--sci-misc/lttoolbox/files/lttoolbox-3.7.1-bashism.patch31
-rw-r--r--sci-misc/lttoolbox/lttoolbox-3.7.1.ebuild43
3 files changed, 75 insertions, 0 deletions
diff --git a/sci-misc/lttoolbox/Manifest b/sci-misc/lttoolbox/Manifest
index d5d51b9e7c2f..03264a9837da 100644
--- a/sci-misc/lttoolbox/Manifest
+++ b/sci-misc/lttoolbox/Manifest
@@ -1 +1,2 @@
DIST lttoolbox-3.3.3.tar.gz 454916 BLAKE2B 20def8f733a979621944e41011838430302140b93ec16e4315b39f60c77d6665c2c553196aea12f1c59ce4172cf3032c867317b8085b1e976fee540a9642d2c9 SHA512 2e6338d39d2f16641c408076bd1d3b29fcd11e2d83e622b93fb7b91bae8eb92f58eacf978c72647d2872119be28b76093fc4afbfe22d7e9a62e1a87d818f9a3c
+DIST lttoolbox-3.7.1.tar.bz2 174427 BLAKE2B 33e2a25f11d4badd30835ff60eeb82dc1f95550ef6814a086115c2279551c0067f2ebdc46574d07d6e01ca459ee41f1f0ea512fae0c1e21e7db6e4b04e70dcad SHA512 e86c5479bf14289a91a9de2a528ebc82ef2df39c39e16b26972b3fc90b372903afd36659be8b9d6c4e5f73b7b40ac6aea8bf56ce58d334462aaddcfc44918724
diff --git a/sci-misc/lttoolbox/files/lttoolbox-3.7.1-bashism.patch b/sci-misc/lttoolbox/files/lttoolbox-3.7.1-bashism.patch
new file mode 100644
index 000000000000..9727c018b142
--- /dev/null
+++ b/sci-misc/lttoolbox/files/lttoolbox-3.7.1-bashism.patch
@@ -0,0 +1,31 @@
+https://github.com/apertium/lttoolbox/pull/171
+
+From 80408b137ceca94d9dab188277ffa3933b148f3d Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 18 Dec 2022 03:33:03 +0000
+Subject: [PATCH] configure.ac: fix bashism
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+configure scripts need to be runnable with a POSIX-compliant /bin/sh.
+
+On many (but not all!) systems, /bin/sh is provided by Bash, so errors
+like this aren't spotted. Notably Debian defaults to /bin/sh provided
+by dash which doesn't tolerate such bashisms as '=='.
+
+This retains compatibility with bash.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/configure.ac
++++ b/configure.ac
+@@ -74,7 +74,7 @@ for version in 23 2b 20 2a 17; do
+ version_flag="-std=c++${version}"
+ AX_CHECK_COMPILE_FLAG([${version_flag}], [break], [version_flag=none])
+ done
+-AS_IF([test "$version_flag" == none], [
++AS_IF([test "$version_flag" = none], [
+ AC_MSG_ERROR([Could not enable at least C++17 - upgrade your compiler])
+ ])
+ CXXFLAGS="$CXXFLAGS ${version_flag}"
+
diff --git a/sci-misc/lttoolbox/lttoolbox-3.7.1.ebuild b/sci-misc/lttoolbox/lttoolbox-3.7.1.ebuild
new file mode 100644
index 000000000000..f06d069fc3c1
--- /dev/null
+++ b/sci-misc/lttoolbox/lttoolbox-3.7.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Toolbox for lexical processing, morphological analysis and generation of words"
+HOMEPAGE="https://www.apertium.org"
+SRC_URI="https://github.com/apertium/lttoolbox/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+# PKG_VERSION_ABI in configure.ac
+SLOT="0/3"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/libxml2:2
+ dev-libs/utfcpp
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.7.1-bashism.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-python-bindings
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}