summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-02 22:55:24 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-02 22:57:47 +0300
commit98df46a8756c33918b7d25c8ada8c13326d8ae1e (patch)
tree13320ac30324d9196561541d1397f9eef700ca78
parentmedia-libs/libvpx: remove svc USE flag (diff)
downloadgentoo-98df46a8.tar.gz
gentoo-98df46a8.tar.bz2
gentoo-98df46a8.zip
dev-python/imageio: add 2.9.0, enable py3.10, enable tests
Closes: https://bugs.gentoo.org/798075 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/imageio/Manifest1
-rw-r--r--dev-python/imageio/imageio-2.9.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/imageio/Manifest b/dev-python/imageio/Manifest
index 5a177910cec5..3f94abe61c1e 100644
--- a/dev-python/imageio/Manifest
+++ b/dev-python/imageio/Manifest
@@ -1 +1,2 @@
DIST imageio-2.6.1.tar.gz 302911 BLAKE2B b0ed781b9edcbb93af664ea4e815cf90e56ab2b31abdda88dcd142558efa1c43afb89886f6b3a372fddcd200df802e45c7278fe13067bfeebf119471f573e668 SHA512 e4a4510a9fd0823914a9f511011cb9c191bea1cd78b2c2bba5d559fcdc89c55cd1dbb03a81eaf82c460ebb86cde518f44ff02766a9935d4f463e81a52007fe25
+DIST imageio-2.9.0.gh.tar.gz 298291 BLAKE2B b36b0a5bf74938177353ffce103d7479a2b15442623d400261dac485b5cc7e8743b18e92d938fcfe2b68dfdef1d1417308e5441112ff851481cc768b76ab56d0 SHA512 a325ad4f0913219b87418d4f57fddc3f1e4c1be4102e933aa0c236317044d2a5ded623bbe86b92d3f2004bb9386ccb3f0cc03b7b118f9faa6f320dd147157ed6
diff --git a/dev-python/imageio/imageio-2.9.0.ebuild b/dev-python/imageio/imageio-2.9.0.ebuild
new file mode 100644
index 000000000000..a90dd3325383
--- /dev/null
+++ b/dev-python/imageio/imageio-2.9.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python library for reading and writing image data"
+HOMEPAGE="https://imageio.github.io/"
+SRC_URI="
+ https://github.com/imageio/imageio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ media-libs/freeimage
+"
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+PROPERTIES="test_network"
+RESTRICT="test"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Fails because of system installed freeimage
+ tests/test_core.py::test_findlib2
+ # Needs unpackaged imageio_ffmpeg
+ tests/test_ffmpeg.py
+ tests/test_ffmpeg_info.py
+)