summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-30 23:00:49 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-30 23:00:49 -0400
commit98f8dbfe2ce048f57b1ce4a95e1c9fec652c2580 (patch)
treeaab82cde2ba2534ebc5c171daf6f15e40082f37b
parentgnome-extra/gnome-software: Version bump to 40.1 (diff)
downloadgentoo-98f8dbfe.tar.gz
gentoo-98f8dbfe.tar.bz2
gentoo-98f8dbfe.zip
gnome-base/librsvg: Version bump to 2.50.5
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--gnome-base/librsvg/Manifest1
-rw-r--r--gnome-base/librsvg/librsvg-2.50.5.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/gnome-base/librsvg/Manifest b/gnome-base/librsvg/Manifest
index fec7b13b5162..1fdf4e56bbc3 100644
--- a/gnome-base/librsvg/Manifest
+++ b/gnome-base/librsvg/Manifest
@@ -1,3 +1,4 @@
DIST librsvg-2.40.21.tar.xz 1655860 BLAKE2B a3fd7915d39984057e860da90115d9d95cef97e61d3f5e4c3aaaf399c4b3bfe781e6a7b969958ae84a3b7f2c788576fe26f56b037ca0a6a2e059b53f2bd1b9fc SHA512 db0563d8e0edaae642a6b2bcd239cf54191495058ac8c7ff614ebaf88c0e30bd58dbcd41f58d82a9d5ed200ced45fc5bae22f2ed3cf3826e9348a497009e1280
DIST librsvg-2.50.3.tar.xz 18868408 BLAKE2B 8b245a233ddd56137880e43f4da2df623237bb1ce2e143cee09da3fadc1edd9b3e4f4753fe48cf814d2372e532775573a34982a6cc88ace9be336e16ae473c20 SHA512 21710b6b5810b959679b7908aa371b8af02c85549efbc64f5fda01cfc3881539b5afc6bc304ce2289719dee48f583b1eb9867546e09f36941f81af968434e389
DIST librsvg-2.50.4.tar.xz 18954216 BLAKE2B 88467cf7b3a7382182f3a37887e9d05dbcb723464607707271491ca20cf7bedb890ec64e1a8c34ab136a23dbfe93dfd19fccbd194c4bd65868b07874c5070067 SHA512 5f476a663e1fa3297d699b1057622e72dbefdf9126ade97762288b7bc4e8a294936d008c889bcaf8e35f46d3b818f5317c63883df0043ec0f8aad18fa5feb4f3
+DIST librsvg-2.50.5.tar.xz 18958716 BLAKE2B 36ca7b9316f0384dfa0063035fe3b57adc9c0a94757b81662e0e80ff19c2388d872353ba2047c8402fd586e4d3614a88e2ba29502bd16c55d8a336238954aaaa SHA512 d1d653031f20a393ba7ae56e3187244cb8e96bfa14f888b07338b80c8d947112c421a88bc57f62eaa6c8b705dde1277a7b56c7cdf602b46c1516309dd4011b56
diff --git a/gnome-base/librsvg/librsvg-2.50.5.ebuild b/gnome-base/librsvg/librsvg-2.50.5.ebuild
new file mode 100644
index 000000000000..4834d74bd38f
--- /dev/null
+++ b/gnome-base/librsvg/librsvg-2.50.5.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 multilib-minimal rust-toolchain vala
+
+DESCRIPTION="Scalable Vector Graphics (SVG) rendering library"
+HOMEPAGE="https://wiki.gnome.org/Projects/LibRsvg"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+IUSE="+introspection +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=x11-libs/cairo-1.16.0[glib,${MULTILIB_USEDEP}]
+ >=media-libs/freetype-2.9:2[${MULTILIB_USEDEP}]
+ >=x11-libs/gdk-pixbuf-2.20:2[introspection?,${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.50.0:2[${MULTILIB_USEDEP}]
+ >=media-libs/harfbuzz-2.0.0:=[${MULTILIB_USEDEP}]
+ >=dev-libs/libxml2-2.9.1-r4:2[${MULTILIB_USEDEP}]
+ >=x11-libs/pango-1.38.0[${MULTILIB_USEDEP}]
+
+ introspection? ( >=dev-libs/gobject-introspection-0.10.8:= )
+"
+DEPEND="${RDEPEND}
+ >=virtual/rust-1.40[${MULTILIB_USEDEP}]
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+# >=gtk-doc-am-1.13, gobject-introspection-common, vala-common needed by eautoreconf
+
+RESTRICT="test" # Lots of issues on 32bit builds, 64bit build seems to get into an infinite compilation sometimes, etc.
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ local myconf=(
+ --disable-static
+ --disable-debug
+ --disable-tools # the tools/ subdirectory is useful only for librsvg devs
+ $(multilib_native_use_enable introspection)
+ $(multilib_native_use_enable vala)
+ --enable-pixbuf-loader
+ )
+
+ if ! multilib_is_native_abi; then
+ myconf+=(
+ # Set the rust target, which can differ from CHOST
+ RUST_TARGET="$(rust_abi)"
+ # RUST_TARGET is only honored if cross_compiling, but non-native ABIs aren't cross as
+ # far as C parts and configure auto-detection are concerned as CHOST equals CBUILD
+ cross_compiling=yes
+ )
+ fi
+
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure "${myconf[@]}"
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/doc/html doc/html || die
+ fi
+}
+
+multilib_src_compile() {
+ # causes segfault if set, see bug #411765
+ unset __GL_NO_DSO_FINALIZER
+ gnome2_src_compile
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ # causes segfault if set, see bug 375615
+ unset __GL_NO_DSO_FINALIZER
+ multilib_foreach_abi gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ # causes segfault if set, see bug 375615
+ unset __GL_NO_DSO_FINALIZER
+ multilib_foreach_abi gnome2_pkg_postrm
+}