summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2021-09-29 19:15:18 -0400
committerBrian Evans <grknight@gentoo.org>2021-09-29 19:15:18 -0400
commit990dbf5a48a258c451d1f0a0e9b7e462ceef3eaf (patch)
treeb8f0dd395c54c528fc01f09b0cf98a0a5f8ae022
parentsys-fs/zfs: sync live ebuild (diff)
downloadgentoo-990dbf5a.tar.gz
gentoo-990dbf5a.tar.bz2
gentoo-990dbf5a.zip
dev-php/pecl-ps: Fix build error with gd detection
Closes: https://bugs.gentoo.org/815388 Signed-off-by: Brian Evans <grknight@gentoo.org>
-rw-r--r--dev-php/pecl-ps/files/ps-1.4.4-fix-gd-detection.patch11
-rw-r--r--dev-php/pecl-ps/pecl-ps-1.4.4.ebuild3
2 files changed, 13 insertions, 1 deletions
diff --git a/dev-php/pecl-ps/files/ps-1.4.4-fix-gd-detection.patch b/dev-php/pecl-ps/files/ps-1.4.4-fix-gd-detection.patch
new file mode 100644
index 000000000000..282bc7a34106
--- /dev/null
+++ b/dev-php/pecl-ps/files/ps-1.4.4-fix-gd-detection.patch
@@ -0,0 +1,11 @@
+--- a/config.m4
++++ b/config.m4
+@@ -38,7 +38,7 @@
+ PHP_ARG_ENABLE([gd],
+ [for GD support],
+ [AS_HELP_STRING([--enable-gd],
+- [Include GD support])])
++ [Include GD support])], no, no)
+
+ if test "$PHP_GD" != "no"; then
+
diff --git a/dev-php/pecl-ps/pecl-ps-1.4.4.ebuild b/dev-php/pecl-ps/pecl-ps-1.4.4.ebuild
index 9de12888a4cc..e010eda79f51 100644
--- a/dev-php/pecl-ps/pecl-ps-1.4.4.ebuild
+++ b/dev-php/pecl-ps/pecl-ps-1.4.4.ebuild
@@ -18,9 +18,10 @@ IUSE="examples gd"
DEPEND="dev-libs/pslib gd? ( media-libs/gd:2= )"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/ps-1.4.4-fix-gd-detection.patch" )
src_configure() {
- PHP_EXT_ECONF_ARGS="$(use_enable gd)"
+ PHP_EXT_ECONF_ARGS=( $(use_enable gd) )
php-ext-source-r3_src_configure
}