summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-03 11:35:30 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-03 11:35:30 +0200
commit991ac772d4fdcf62a35ba2aafb2d2db9564e566b (patch)
treea0b05aba791db503e25015e21623a8e85ead8280
parentdev-libs/boost: enable py3.11 (diff)
downloadgentoo-991ac772d4fdcf62a35ba2aafb2d2db9564e566b.tar.gz
gentoo-991ac772d4fdcf62a35ba2aafb2d2db9564e566b.tar.bz2
gentoo-991ac772d4fdcf62a35ba2aafb2d2db9564e566b.zip
app-crypt/libnitrokey: call udev_reload in pkg_postinst/pkg_postrm
Closes: https://bugs.gentoo.org/854243 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--app-crypt/libnitrokey/libnitrokey-3.6.ebuild10
-rw-r--r--app-crypt/libnitrokey/libnitrokey-9999.ebuild10
2 files changed, 18 insertions, 2 deletions
diff --git a/app-crypt/libnitrokey/libnitrokey-3.6.ebuild b/app-crypt/libnitrokey/libnitrokey-3.6.ebuild
index ecef8c9b5c2d..dd6d0126cf31 100644
--- a/app-crypt/libnitrokey/libnitrokey-3.6.ebuild
+++ b/app-crypt/libnitrokey/libnitrokey-3.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -45,3 +45,11 @@ src_configure() {
)
cmake_src_configure
}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}
diff --git a/app-crypt/libnitrokey/libnitrokey-9999.ebuild b/app-crypt/libnitrokey/libnitrokey-9999.ebuild
index 8687d0d1b4e3..a9135e08d5d4 100644
--- a/app-crypt/libnitrokey/libnitrokey-9999.ebuild
+++ b/app-crypt/libnitrokey/libnitrokey-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -45,3 +45,11 @@ src_configure() {
)
cmake_src_configure
}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}