summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-12 09:42:03 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-12 10:40:29 +0100
commit992673293852f221cecb5dd4c7b98f8b6e0743d4 (patch)
tree47592f4e7d9cc5cdd65c38bbd470edba66acbe3c
parentdev-python/soupsieve: Bump to 2.3.1 (diff)
downloadgentoo-992673293852f221cecb5dd4c7b98f8b6e0743d4.tar.gz
gentoo-992673293852f221cecb5dd4c7b98f8b6e0743d4.tar.bz2
gentoo-992673293852f221cecb5dd4c7b98f8b6e0743d4.zip
dev-python/jaraco-envs: Bump to 2.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jaraco-envs/Manifest1
-rw-r--r--dev-python/jaraco-envs/jaraco-envs-2.2.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/jaraco-envs/Manifest b/dev-python/jaraco-envs/Manifest
index 79d1aadc3384..cfedbc64db53 100644
--- a/dev-python/jaraco-envs/Manifest
+++ b/dev-python/jaraco-envs/Manifest
@@ -1 +1,2 @@
DIST jaraco.envs-2.1.1.tar.gz 10190 BLAKE2B 3b191549fe8a5cee1a964559f7ecba8305ac22cc1980191c7fd967a8fb5eac7c81cd8a2752566e2d0e820a9d089422d11fc5529f56d4266cae411ce13e304bb8 SHA512 c71aab9748cfa31c27bb7899117e15d2836851a47a76b638177facc89e894dfa2c4168da2d5b1873b1eeed0d785d23137e56e198f92fb83deb26aab38e342ad2
+DIST jaraco.envs-2.2.0.tar.gz 6151 BLAKE2B a620bb64ffad881e9b31569d90b621ac79f27ff78c6531f0e89e7f4cf386a4a8045aa9676e561b51d75ce1bef82b4f86342fb51dfe1a1acc32eeae58b4237373 SHA512 b852168f718c133142b592402d17891cad821493842324263c195d0c6d15592946c89431d278b4860f8802363debce87f35e11f1357a52b94620bcc3f90d99ec
diff --git a/dev-python/jaraco-envs/jaraco-envs-2.2.0.ebuild b/dev-python/jaraco-envs/jaraco-envs-2.2.0.ebuild
new file mode 100644
index 000000000000..b601de93161c
--- /dev/null
+++ b/dev-python/jaraco-envs/jaraco-envs-2.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="Classes for orchestrating Python (virtual) environments."
+HOMEPAGE="https://github.com/jaraco/jaraco.envs"
+SRC_URI="mirror://pypi/${MY_P::1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/path-py[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/contextlib2[${PYTHON_USEDEP}]' 'python3_[67]')"
+# toml is required by setuptools_scm
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]"
+
+# there are no actual tests, just flake8 etc
+RESTRICT="test"