summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-06-26 23:44:46 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-06-26 23:49:00 -0400
commit994e3131ef0fa624500d324a88b51abf6ddcd88d (patch)
tree095e22a0f8e902d2201f71ba3ea65f5296a8b700
parentx11-drivers/nvidia-drivers: add 525.125.06 (diff)
downloadgentoo-994e3131ef0fa624500d324a88b51abf6ddcd88d.tar.gz
gentoo-994e3131ef0fa624500d324a88b51abf6ddcd88d.tar.bz2
gentoo-994e3131ef0fa624500d324a88b51abf6ddcd88d.zip
gui-libs/egl-gbm: add 1.1.0_p20230420
Seems nvidia been bumping their bundled copy but without making releases, so guess should use snapshots... (this is mentioned in the nvidia-drivers-525.125.06's ChangeLog file which appears to refer to a fix that's not in a release) Please report if any problems as I don't really test wayland/GBM. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--gui-libs/egl-gbm/Manifest1
-rw-r--r--gui-libs/egl-gbm/egl-gbm-1.1.0_p20230420.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/gui-libs/egl-gbm/Manifest b/gui-libs/egl-gbm/Manifest
index 89e67167b684..d0fa29f6d07e 100644
--- a/gui-libs/egl-gbm/Manifest
+++ b/gui-libs/egl-gbm/Manifest
@@ -1 +1,2 @@
DIST egl-gbm-1.1.0.tar.gz 17165 BLAKE2B c83702635c7621d93968ed6813d3641bcc785b7e6fb0474d1e6edebf46942c799af52d22127865ff9484ef6b398a02cb6081dfc00a6e1ec8ce1882c0c980b116 SHA512 4b7856f496bd045d1ef56881ac793c9e5994bb6cfaa911de51f83bfd4adcf596c204a75cd9f1aef0418289dcef4812ace8cba23b44445e18e004bf6ad2b18421
+DIST egl-gbm-1.1.0_p20230420.tar.gz 17705 BLAKE2B 374b031918bb08bb5c98a9c1a67c18c56685ca4518a239ebd489f3fea9f270659d4113fb0a9f7fc74c6b98d71335160bf71b0e1dc46907ec1eaf67ffc41aa6e3 SHA512 025c2b2118e7a3ae1f17e79a16bba41683f93b413b3fee9bf9115d8392a8822a05368936080cc545515d7ef553052d002307ccc8783413129f0887cee2b6de9c
diff --git a/gui-libs/egl-gbm/egl-gbm-1.1.0_p20230420.ebuild b/gui-libs/egl-gbm/egl-gbm-1.1.0_p20230420.ebuild
new file mode 100644
index 000000000000..669004695aad
--- /dev/null
+++ b/gui-libs/egl-gbm/egl-gbm-1.1.0_p20230420.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+HASH_EGLGBM=e5eee6058a812bce6df792c54efc484c4f15b6d1
+
+DESCRIPTION="GBM EGL external platform library"
+HOMEPAGE="https://github.com/NVIDIA/egl-gbm/"
+SRC_URI="https://github.com/NVIDIA/egl-gbm/archive/${HASH_EGLGBM}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${HASH_EGLGBM}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ >=media-libs/mesa-21.2[gbm(+)]
+ x11-libs/libdrm
+ !<x11-drivers/nvidia-drivers-495.46-r20[wayland(-)]"
+DEPEND="
+ ${RDEPEND}
+ >=media-libs/libglvnd-1.3.4
+ gui-libs/eglexternalplatform"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.0-werror.patch
+)
+
+src_install() {
+ meson_src_install
+
+ insinto /usr/share/egl/egl_external_platform.d
+ doins "${FILESDIR}"/15_nvidia_gbm.json
+}