summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2019-11-02 14:40:03 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2019-11-02 14:40:24 -0700
commit995223f937ca2dbfb7b15e09fdae4adbbf93f536 (patch)
tree9d3e77562e6cdfd2e5bc45870a6425a5ac2fb824
parentnet-mail/rss2email: 3.11 + py35 support (diff)
downloadgentoo-995223f937ca2dbfb7b15e09fdae4adbbf93f536.tar.gz
gentoo-995223f937ca2dbfb7b15e09fdae4adbbf93f536.tar.bz2
gentoo-995223f937ca2dbfb7b15e09fdae4adbbf93f536.zip
net-mail/qlogtools: Update to EAPI7
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> Bug: https://bugs.gentoo.org/show_bug.cgi?id=697246
-rw-r--r--net-mail/qlogtools/qlogtools-3.1-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-mail/qlogtools/qlogtools-3.1-r1.ebuild b/net-mail/qlogtools/qlogtools-3.1-r1.ebuild
new file mode 100644
index 000000000000..df13e770840a
--- /dev/null
+++ b/net-mail/qlogtools/qlogtools-3.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Qmail Log processing tools"
+HOMEPAGE="http://untroubled.org/qlogtools/"
+SRC_URI="http://untroubled.org/qlogtools/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!app-text/multitail"
+
+PATCHES=(
+ "${FILESDIR}"/qlogtools-3.1-errno.patch
+)
+
+src_configure() {
+ echo "$(tc-getCC) ${CFLAGS}" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
+ echo "${D}/usr/bin" > conf-bin
+ echo "${D}/usr/share/man/" > conf-man
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/man/
+ ./installer || die "Installer failed"
+ dodoc ANNOUNCEMENT FILES NEWS README TARGETS VERSION
+}
+
+pkg_postinst() {
+ elog "Please see /usr/share/doc/${PF}/README for configuration information"
+}