summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2017-08-28 19:26:09 +0200
committerGuilherme Amadio <amadio@gentoo.org>2017-08-28 19:26:40 +0200
commit996c239647552cf44de1eda5be28d97744ab46e8 (patch)
treebda3bd1fb74b9468b44b25646d637daa4f286e13
parentwww-client/opera-developer: Old. (diff)
downloadgentoo-996c2396.tar.gz
gentoo-996c2396.tar.bz2
gentoo-996c2396.zip
dev-python/m2crypto: add prefix support
Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--dev-python/m2crypto/m2crypto-0.26.0.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/m2crypto/m2crypto-0.26.0.ebuild b/dev-python/m2crypto/m2crypto-0.26.0.ebuild
index f6ebb3ee9016..55a09e511603 100644
--- a/dev-python/m2crypto/m2crypto-0.26.0.ebuild
+++ b/dev-python/m2crypto/m2crypto-0.26.0.ebuild
@@ -16,7 +16,8 @@ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+
IUSE="libressl"
RDEPEND="
@@ -34,6 +35,10 @@ S="${WORKDIR}/${MY_PN}-${PV}"
# Tests access network, and fail randomly. Bug #431458.
RESTRICT=test
+python_compile() {
+ distutils-r1_python_compile --openssl="${EPREFIX}"/usr
+}
+
python_test() {
esetup.py test
}