summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2023-03-18 19:54:37 +0100
committerViorel Munteanu <ceamac@gentoo.org>2023-04-11 08:29:43 +0300
commit998fda58ce8b81855ad9472de53a58fbb7244a72 (patch)
tree5c2454c694b8f06f519ddc747dd2236fac6bf386
parentwww-client/firefox-bin: drop 111.0.1 (diff)
downloadgentoo-998fda58ce8b81855ad9472de53a58fbb7244a72.tar.gz
gentoo-998fda58ce8b81855ad9472de53a58fbb7244a72.tar.bz2
gentoo-998fda58ce8b81855ad9472de53a58fbb7244a72.zip
media-gfx/alembic: add 1.8.5
Drop python test for now, until issue of failing test is resolved. Bug: https://github.com/alembic/alembic/issues/411 Closes: https://bugs.gentoo.org/901203 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/30218 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
-rw-r--r--media-gfx/alembic/Manifest1
-rw-r--r--media-gfx/alembic/alembic-1.8.5.ebuild71
-rw-r--r--media-gfx/alembic/files/alembic-1.8.5-set-correct-libdir.patch48
3 files changed, 120 insertions, 0 deletions
diff --git a/media-gfx/alembic/Manifest b/media-gfx/alembic/Manifest
index 945025e06f5b..158586ffd746 100644
--- a/media-gfx/alembic/Manifest
+++ b/media-gfx/alembic/Manifest
@@ -1 +1,2 @@
DIST alembic-1.8.4.tar.gz 867788 BLAKE2B b7bc5ebcaebc5905a9a2e45be21170a72923fd6af6d9f97b81bdc7e8b80bb037ed3f667ea15a5b96194b33687010fda455e4df8355f92fc29aa000beae32cae8 SHA512 2473f4b9afe3fddbd2d0477bdc85d93697e413410253a7f7f0f030fba919dfb63dabd2d2d13829f59f3f901643ab842d230a9f08fb667e2c16cef0e751a8a687
+DIST alembic-1.8.5.tar.gz 867976 BLAKE2B 715ff6212ab78b2b4d3f5ea3b448468ade488008a8362193b4976671a69ad89337f926082c7736e64a0b07bf71e04d774df5e22abe409f8cfab1a15ccb3c86bb SHA512 89a480970eb09893112bf650011ede852205d1fa3718680a3983392bbcf3eb3f22f4ec01f42d12bfcaf655ce43d7d6f583b764ec03f4c5a84023359502b3636e
diff --git a/media-gfx/alembic/alembic-1.8.5.ebuild b/media-gfx/alembic/alembic-1.8.5.ebuild
new file mode 100644
index 000000000000..acfb913ecfbc
--- /dev/null
+++ b/media-gfx/alembic/alembic-1.8.5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit cmake python-single-r1
+
+DESCRIPTION="Open framework for storing and sharing scene data"
+HOMEPAGE="https://www.alembic.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="examples hdf5 python test"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ examples? ( python )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/imath:=
+ python? ( dev-libs/imath:=[python,${PYTHON_SINGLE_USEDEP}] )
+ hdf5? (
+ >=sci-libs/hdf5-1.10.2:=[zlib(+)]
+ >=sys-libs/zlib-1.2.11-r1
+ )
+ python? ( $(python_gen_cond_dep 'dev-libs/boost[python,${PYTHON_USEDEP}]') )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.8.5-set-correct-libdir.patch )
+
+DOCS=( ACKNOWLEDGEMENTS.txt FEEDBACK.txt NEWS.txt README.txt )
+
+src_prepare() {
+ cmake_src_prepare
+ cmake_run_in "${S}/python/PyAlembic" cmake_comment_add_subdirectory Tests
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DALEMBIC_BUILD_LIBS=ON
+ -DALEMBIC_DEBUG_WARNINGS_AS_ERRORS=OFF
+ -DALEMBIC_SHARED_LIBS=ON
+ # currently does nothing but require doxygen
+ -DDOCS_PATH=OFF
+ -DUSE_ARNOLD=OFF
+ -DUSE_BINARIES=ON
+ -DUSE_EXAMPLES=$(usex examples)
+ -DUSE_HDF5=$(usex hdf5)
+ -DUSE_MAYA=OFF
+ -DUSE_PRMAN=OFF
+ -DUSE_PYALEMBIC=$(usex python)
+ -DUSE_TESTS=$(usex test)
+ )
+
+ use python && mycmakeargs+=( -DPython3_EXECUTABLE=${PYTHON} )
+
+ cmake_src_configure
+}
+
+# some tests may fail if run in parallel mode
+# see https://github.com/alembic/alembic/issues/401
+src_test() {
+ cmake_src_test -j1
+}
diff --git a/media-gfx/alembic/files/alembic-1.8.5-set-correct-libdir.patch b/media-gfx/alembic/files/alembic-1.8.5-set-correct-libdir.patch
new file mode 100644
index 000000000000..70071a68e49b
--- /dev/null
+++ b/media-gfx/alembic/files/alembic-1.8.5-set-correct-libdir.patch
@@ -0,0 +1,48 @@
+From fade0b08f9343fa3cd941b281a3ce49a1918acca Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl-gentoo@posteo.net>
+Date: Sat, 18 Mar 2023 19:08:51 +0100
+Subject: [PATCH] Gentoo-specific: set correct libdir
+
+Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -74,12 +74,12 @@ option(DOCS_PATH
+
+ # Set static/dynamic build options
+ SET(LIB_TYPE STATIC)
+-SET(RUNTIME_INSTALL_DIR lib)
+-SET(LIBRARY_INSTALL_DIR lib)
+-SET(ARCHIVE_INSTALL_DIR lib)
++SET(RUNTIME_INSTALL_DIR lib${LIB_SUFFIX})
++SET(LIBRARY_INSTALL_DIR lib${LIB_SUFFIX})
++SET(ARCHIVE_INSTALL_DIR lib${LIB_SUFFIX})
+ IF (ALEMBIC_SHARED_LIBS)
+ SET(LIB_TYPE SHARED)
+- SET(ARCHIVE_INSTALL_DIR lib)
++ SET(ARCHIVE_INSTALL_DIR lib${LIB_SUFFIX})
+ IF (WIN32)
+ ADD_DEFINITIONS(-DALEMBIC_DLL)
+ ENDIF()
+--- a/lib/Alembic/CMakeLists.txt
++++ b/lib/Alembic/CMakeLists.txt
+@@ -84,7 +84,7 @@ TARGET_LINK_LIBRARIES(Alembic
+ ${ZLIB_LIBRARY}
+ )
+
+-SET( ALEMBIC_LIB_INSTALL_DIR lib CACHE STRING "Where to install the Alembic libs")
++SET( ALEMBIC_LIB_INSTALL_DIR lib${LIB_SUFFIX} CACHE STRING "Where to install the Alembic libs")
+ INSTALL(TARGETS Alembic
+ EXPORT AlembicTargets
+ LIBRARY DESTINATION ${ALEMBIC_LIB_INSTALL_DIR}
+@@ -97,7 +97,7 @@ INSTALL(TARGETS Alembic
+
+ set(alembic_targets_file "${PROJECT_NAME}Targets.cmake")
+
+-SET(ConfigPackageLocation lib/cmake/Alembic CACHE PATH
++SET(ConfigPackageLocation lib${LIB_SUFFIX}/cmake/Alembic CACHE PATH
+ "Where to install the Alembic's cmake files")
+
+ INCLUDE(CMakePackageConfigHelpers)
+--
+2.40.0
+