summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-12 06:15:41 +0100
committerSam James <sam@gentoo.org>2024-05-12 06:15:57 +0100
commit9998cdf862f9b0a486bf36922cdc2f08d4cac44d (patch)
tree9524eb767e81c58cccb782ecb1668eb2c95eb4d4
parentdev-ruby/reline: add 0.5.6 (diff)
downloadgentoo-9998cdf862f9b0a486bf36922cdc2f08d4cac44d.tar.gz
gentoo-9998cdf862f9b0a486bf36922cdc2f08d4cac44d.tar.bz2
gentoo-9998cdf862f9b0a486bf36922cdc2f08d4cac44d.zip
net-nds/ldapvi: fix modern C issue
Thanks to NHO. Closes: https://bugs.gentoo.org/885885 Closes: https://bugs.gentoo.org/921256 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-nds/ldapvi/files/ldapvi-1.7-posix-unlocked.patch23
-rw-r--r--net-nds/ldapvi/ldapvi-1.7_p20101214-r7.ebuild63
2 files changed, 86 insertions, 0 deletions
diff --git a/net-nds/ldapvi/files/ldapvi-1.7-posix-unlocked.patch b/net-nds/ldapvi/files/ldapvi-1.7-posix-unlocked.patch
new file mode 100644
index 000000000000..167a2ce95b2f
--- /dev/null
+++ b/net-nds/ldapvi/files/ldapvi-1.7-posix-unlocked.patch
@@ -0,0 +1,23 @@
+https://bugs.gentoo.org/885885
+--- a/parse.c
++++ b/parse.c
+@@ -15,7 +15,7 @@
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+-#define _XOPEN_SOURCE
++#define _XOPEN_SOURCE 700
+ #include <unistd.h>
+ #include <crypt.h>
+ #include <stdio.h>
+--- a/parseldif.c
++++ b/parseldif.c
+@@ -15,7 +15,7 @@
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+-#define _XOPEN_SOURCE
++#define _XOPEN_SOURCE 700
+ #include <unistd.h>
+ #include <stdio.h>
+ #include "common.h"
diff --git a/net-nds/ldapvi/ldapvi-1.7_p20101214-r7.ebuild b/net-nds/ldapvi/ldapvi-1.7_p20101214-r7.ebuild
new file mode 100644
index 000000000000..f370745a1ef8
--- /dev/null
+++ b/net-nds/ldapvi/ldapvi-1.7_p20101214-r7.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Manage LDAP entries with a text editor"
+HOMEPAGE="http://www.lichteblau.com/ldapvi/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+S="${WORKDIR}"/${P}/${PN}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="gnutls sasl"
+
+RDEPEND="
+ dev-libs/popt
+ dev-libs/glib:2
+ sys-libs/readline:=
+ sys-libs/ncurses:=
+ virtual/libcrypt:=
+ gnutls? (
+ net-libs/gnutls:=
+ net-nds/openldap[gnutls]
+ )
+ !gnutls? (
+ dev-libs/openssl:=
+ net-nds/openldap[ssl]
+ )
+ sasl? ( dev-libs/cyrus-sasl:2[ssl] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.7-fix-implicit-function-declarations.patch"
+ "${FILESDIR}/${PN}-1.7-fix-missing-on_exit-musl.patch"
+ "${FILESDIR}/${PN}-1.7-posix-unlocked.patch"
+)
+
+src_prepare() {
+ default
+
+ # bug #459478
+ sed -i \
+ -e '/^AC_SEARCH_LIBS/s:curses ncurses:curses ncurses tinfo:' \
+ configure.in || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-libcrypto=$(usex gnutls gnutls openssl)
+}
+
+src_install() {
+ dobin ldapvi
+ doman ldapvi.1
+ dodoc NEWS manual/{bg.png,html.xsl,manual.{css,xml}}
+}