summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 18:43:06 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:34:22 +0100
commit999e53d96063e3eaf5ca64a3e9c0050b0de48a3c (patch)
tree5e13cbe8ba0550fa6a73f0e4c7f6874a5c10918e
parentnet-wireless/gr-doa: Switch to PYTHON_SINGLE_USEDEP (diff)
downloadgentoo-999e53d9.tar.gz
gentoo-999e53d9.tar.bz2
gentoo-999e53d9.zip
net-wireless/gr-foo: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--net-wireless/gr-foo/gr-foo-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/net-wireless/gr-foo/gr-foo-9999.ebuild b/net-wireless/gr-foo/gr-foo-9999.ebuild
index b54cc9402c9a..035e0e058a23 100644
--- a/net-wireless/gr-foo/gr-foo-9999.ebuild
+++ b/net-wireless/gr-foo/gr-foo-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,9 +22,11 @@ SLOT="0/${PV}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
- dev-libs/boost:=[${PYTHON_USEDEP}]
- >=net-wireless/gnuradio-3.7_rc:0=[${PYTHON_USEDEP}]
- net-wireless/uhd:=[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-libs/boost:=[${PYTHON_MULTI_USEDEP}]
+ ')
+ >=net-wireless/gnuradio-3.7_rc:0=[${PYTHON_SINGLE_USEDEP}]
+ net-wireless/uhd:=[${PYTHON_SINGLE_USEDEP}]
"
DEPEND="${RDEPEND}
dev-lang/swig:0