summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2023-03-04 00:15:34 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-03-04 00:16:39 +0100
commit99e0063b4eef21cfa623854ebc9458448760d6ee (patch)
treeaa9524d35c64c787f6542aba9e7b180d79b568f2
parentapp-dicts/aspell-pl: add 6.0.20230301.0 (diff)
downloadgentoo-99e0063b.tar.gz
gentoo-99e0063b.tar.bz2
gentoo-99e0063b.zip
sys-apps/cpuid: add 20230228
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--sys-apps/cpuid/Manifest1
-rw-r--r--sys-apps/cpuid/cpuid-20230228.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/cpuid/Manifest b/sys-apps/cpuid/Manifest
index c097cb498604..8792444ffc76 100644
--- a/sys-apps/cpuid/Manifest
+++ b/sys-apps/cpuid/Manifest
@@ -1,2 +1,3 @@
DIST cpuid-20221201.src.tar.gz 140185 BLAKE2B f9bef888adaaddc9f0b28d85905ab4c86b65b1ef247b7068f0fd7a508021f3ff8322287c5284ae0041effc71b07661a265426f28116faa700edb2fc793452c69 SHA512 fb6ace9c8d7efae628087bdce9d8279c080701b37ecc57f5c9b5d63b0c1991bc0f2c26a2708467e479169f72a41d93c0a70e156726babd5adab366b38ca309c9
DIST cpuid-20230120.src.tar.gz 141652 BLAKE2B 54843915be232762e35e6dfed3b7b582d192838bdc5e3b7ebb88b9ada217a3fd21d40faf248244047664f52c8e0c0689196b4373b01c2988aaa3738b7e69af3d SHA512 2b662c2db0ad013626245190be34aa3c04c01bb694111aafc4a491e0816fbb38d94e3d9b20770050efce0c08e6eaa9b22f6c8e9ea304d195afae17b6a4bbf2ab
+DIST cpuid-20230228.src.tar.gz 143114 BLAKE2B c5b6023b8dd51820bfb1b87be8365df674d4086d79d6d9018617ac9e29fa59dcb8617da8de68a9d20190d966e7d5211fa5f37b9d7b6b7ae55b8e061a924b3ce0 SHA512 ff0afc6eaa537dc786aaee542d9905164a30f5f11aed493480beac27b310656cbc11483d091beaf84f781b4dcccb24645c3260d385147fd6936df181ea09841b
diff --git a/sys-apps/cpuid/cpuid-20230228.ebuild b/sys-apps/cpuid/cpuid-20230228.ebuild
new file mode 100644
index 000000000000..18c1efcd3afe
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20230228.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux tool to dump x86 CPUID information about the CPUs"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+BDEPEND="
+ app-arch/gzip
+ dev-lang/perl
+"
+
+DOCS=( "ChangeLog" "FUTURE" )
+
+PATCHES=( "${FILESDIR}/${PN}-20220620-makefile.patch" )
+
+src_prepare() {
+ default
+
+ tc-export CC
+}
+
+src_install() {
+ emake BUILDROOT="${ED}" install
+
+ einstalldocs
+}