summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-08-11 12:00:52 +0200
committerJeroen Roovers <jer@gentoo.org>2019-08-11 12:06:09 +0200
commit99e1f61d11b69b9917932542a65fe3948b4a4e25 (patch)
treefa08829680338c6e1242b2b1ca8d00606e136e2f
parentdev-libs/liblinear: Revert "Add IUSE=blas." (diff)
downloadgentoo-99e1f61d11b69b9917932542a65fe3948b4a4e25.tar.gz
gentoo-99e1f61d11b69b9917932542a65fe3948b4a4e25.tar.bz2
gentoo-99e1f61d11b69b9917932542a65fe3948b4a4e25.zip
net-analyzer/nmap: SUBDIRS: Use a patch instead of a sed script
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--net-analyzer/nmap/files/nmap-7.80-ac-config-subdirs.patch26
-rw-r--r--net-analyzer/nmap/nmap-7.80.ebuild6
-rw-r--r--net-analyzer/nmap/nmap-9999.ebuild6
3 files changed, 28 insertions, 10 deletions
diff --git a/net-analyzer/nmap/files/nmap-7.80-ac-config-subdirs.patch b/net-analyzer/nmap/files/nmap-7.80-ac-config-subdirs.patch
new file mode 100644
index 000000000000..583f7f1d1aa3
--- /dev/null
+++ b/net-analyzer/nmap/files/nmap-7.80-ac-config-subdirs.patch
@@ -0,0 +1,26 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -468,7 +468,6 @@
+ fi
+
+ if test $have_libpcap != yes; then
+- AC_CONFIG_SUBDIRS(libpcap)
+ if test "${LIBPCAP_INC+set}" = "set"; then
+ CPPFLAGS="$CPPFLAGS -I$LIBPCAP_INC"
+ else
+@@ -611,7 +610,6 @@
+ fi
+
+ if test $have_libz != yes; then
+- AC_CONFIG_SUBDIRS(libz)
+ # TODO: This doesn't work because libssh2's configure script is looking for
+ # already-built libs. Giving up for now: build libz first or install
+ # headers/libs on your own if you want compression support for SSH.
+@@ -697,7 +695,6 @@
+ # If we still don't have it, we use our own
+ if test $have_libssh2 != yes; then
+ have_libssh2=yes
+- AC_CONFIG_SUBDIRS(libssh2)
+ CPPFLAGS="-I\$(top_srcdir)/$LIBSSH2DIR/include $CPPFLAGS"
+ LIBSSH2_LIBS="$LIBSSH2DIR/lib/libssh2.a"
+ LIBSSH2_BUILD="build-libssh2"
diff --git a/net-analyzer/nmap/nmap-7.80.ebuild b/net-analyzer/nmap/nmap-7.80.ebuild
index cf94423c0af1..b3ddc62aa35b 100644
--- a/net-analyzer/nmap/nmap-7.80.ebuild
+++ b/net-analyzer/nmap/nmap-7.80.ebuild
@@ -67,6 +67,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-7.25-CXXFLAGS.patch
"${FILESDIR}"/${PN}-7.25-libpcre.patch
"${FILESDIR}"/${PN}-7.31-libnl.patch
+ "${FILESDIR}"/${PN}-7.80-ac-config-subdirs.patch
)
S="${WORKDIR}/${MY_P}"
@@ -108,11 +109,6 @@ src_prepare() {
zenmap/install_scripts/unix/zenmap-root.desktop \
zenmap/install_scripts/unix/zenmap.desktop || die
- sed -i \
- -e '/AC_CONFIG_SUBDIRS(libz)/d' \
- -e '/AC_CONFIG_SUBDIRS(libssh2)/d' \
- configure.ac
-
cp libdnet-stripped/include/config.h.in{,.nmap-orig} || die
eautoreconf
diff --git a/net-analyzer/nmap/nmap-9999.ebuild b/net-analyzer/nmap/nmap-9999.ebuild
index 6b625c9459bf..4c5cd498f494 100644
--- a/net-analyzer/nmap/nmap-9999.ebuild
+++ b/net-analyzer/nmap/nmap-9999.ebuild
@@ -65,6 +65,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-7.25-CXXFLAGS.patch
"${FILESDIR}"/${PN}-7.25-libpcre.patch
"${FILESDIR}"/${PN}-7.31-libnl.patch
+ "${FILESDIR}"/${PN}-7.80-ac-config-subdirs.patch
)
S="${WORKDIR}/${MY_P}"
@@ -106,11 +107,6 @@ src_prepare() {
zenmap/install_scripts/unix/zenmap-root.desktop \
zenmap/install_scripts/unix/zenmap.desktop || die
- sed -i \
- -e '/AC_CONFIG_SUBDIRS(libz)/d' \
- -e '/AC_CONFIG_SUBDIRS(libssh2)/d' \
- configure.ac
-
cp libdnet-stripped/include/config.h.in{,.nmap-orig} || die
eautoreconf