summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2023-06-26 23:32:35 +0100
committerJames Le Cuirot <chewi@gentoo.org>2023-06-26 23:33:18 +0100
commit99e585bac78e0aa1445717d9c302f030d64a6aec (patch)
treed14b1c71cb53a7cc4f795c16d39d882b3f38e78e
parentdev-python/vcrpy: 5.0.0 (diff)
downloadgentoo-99e585bac78e0aa1445717d9c302f030d64a6aec.tar.gz
gentoo-99e585bac78e0aa1445717d9c302f030d64a6aec.tar.bz2
gentoo-99e585bac78e0aa1445717d9c302f030d64a6aec.zip
x11-wm/xpra: Conditionally require pillow[webp] and drop pillow USE flag
We have had pillow as an unconditional dependency for ages. It is technically optional, but upstream strongly recommends it. Closes: https://bugs.gentoo.org/799752 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--x11-wm/xpra/metadata.xml1
-rw-r--r--x11-wm/xpra/xpra-4.4.5-r2.ebuild2
-rw-r--r--x11-wm/xpra/xpra-4.4.6-r1.ebuild (renamed from x11-wm/xpra/xpra-4.4.6.ebuild)4
-rw-r--r--x11-wm/xpra/xpra-9999.ebuild4
4 files changed, 5 insertions, 6 deletions
diff --git a/x11-wm/xpra/metadata.xml b/x11-wm/xpra/metadata.xml
index 48743006848c..851f88503995 100644
--- a/x11-wm/xpra/metadata.xml
+++ b/x11-wm/xpra/metadata.xml
@@ -25,7 +25,6 @@
<flag name="html">Install the HTML5 client</flag>
<flag name="ibus">Use ibus input method via <pkg>app-i18n/ibus</pkg></flag>
<flag name="oauth">Enable OAuth2 authentication in the server</flag>
- <flag name="pillow">Enable pillow support</flag>
<flag name="pinentry">Use <pkg>app-crypt/pinentry</pkg> for password entry</flag>
<flag name="trayicon">Enable system tray icon</flag>
<flag name="server">Build server-side code</flag>
diff --git a/x11-wm/xpra/xpra-4.4.5-r2.ebuild b/x11-wm/xpra/xpra-4.4.5-r2.ebuild
index 2c08072e01a5..64f6dfde2400 100644
--- a/x11-wm/xpra/xpra-4.4.5-r2.ebuild
+++ b/x11-wm/xpra/xpra-4.4.5-r2.ebuild
@@ -22,7 +22,7 @@ DESCRIPTION="X Persistent Remote Apps (xpra) and Partitioning WM (parti) based o
HOMEPAGE="https://xpra.org/"
LICENSE="GPL-2 BSD"
SLOT="0"
-IUSE="brotli +client +clipboard crypt csc cups dbus doc ffmpeg jpeg html ibus +lz4 lzo minimal oauth opengl pillow pinentry pulseaudio +server sound systemd test +trayicon udev vpx webcam webp xdg xinerama"
+IUSE="brotli +client +clipboard crypt csc cups dbus doc ffmpeg jpeg html ibus +lz4 lzo minimal oauth opengl pinentry pulseaudio +server sound systemd test +trayicon udev vpx webcam webp xdg xinerama"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
|| ( client server )
diff --git a/x11-wm/xpra/xpra-4.4.6.ebuild b/x11-wm/xpra/xpra-4.4.6-r1.ebuild
index 45f19d022704..322e28c739e9 100644
--- a/x11-wm/xpra/xpra-4.4.6.ebuild
+++ b/x11-wm/xpra/xpra-4.4.6-r1.ebuild
@@ -22,7 +22,7 @@ DESCRIPTION="X Persistent Remote Apps (xpra) and Partitioning WM (parti) based o
HOMEPAGE="https://xpra.org/"
LICENSE="GPL-2 BSD"
SLOT="0"
-IUSE="brotli +client +clipboard crypt csc cups dbus doc ffmpeg jpeg html ibus +lz4 lzo minimal oauth opengl pillow pinentry pulseaudio +server sound systemd test +trayicon udev vpx webcam webp xdg xinerama"
+IUSE="brotli +client +clipboard crypt csc cups dbus doc ffmpeg jpeg html ibus +lz4 lzo minimal oauth opengl pinentry pulseaudio +server sound systemd test +trayicon udev vpx webcam webp xdg xinerama"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
|| ( client server )
@@ -35,7 +35,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
TEST_DEPEND="
$(python_gen_cond_dep '
dev-python/netifaces[${PYTHON_USEDEP}]
- dev-python/pillow[jpeg?,${PYTHON_USEDEP}]
+ dev-python/pillow[jpeg?,webp?,${PYTHON_USEDEP}]
dev-python/rencode[${PYTHON_USEDEP}]
dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
xdg? ( dev-python/pyxdg[${PYTHON_USEDEP}] )
diff --git a/x11-wm/xpra/xpra-9999.ebuild b/x11-wm/xpra/xpra-9999.ebuild
index 052a2654219b..bc63326e1601 100644
--- a/x11-wm/xpra/xpra-9999.ebuild
+++ b/x11-wm/xpra/xpra-9999.ebuild
@@ -22,7 +22,7 @@ DESCRIPTION="X Persistent Remote Apps (xpra) and Partitioning WM (parti) based o
HOMEPAGE="https://xpra.org/"
LICENSE="GPL-2 BSD"
SLOT="0"
-IUSE="brotli +client +clipboard crypt csc cups dbus doc ffmpeg jpeg html ibus +lz4 lzo minimal oauth opengl pillow pinentry pulseaudio +server sound systemd test +trayicon udev vpx webcam webp xdg xinerama"
+IUSE="brotli +client +clipboard crypt csc cups dbus doc ffmpeg jpeg html ibus +lz4 lzo minimal oauth opengl pinentry pulseaudio +server sound systemd test +trayicon udev vpx webcam webp xdg xinerama"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
|| ( client server )
@@ -35,7 +35,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
TEST_DEPEND="
$(python_gen_cond_dep '
dev-python/netifaces[${PYTHON_USEDEP}]
- dev-python/pillow[jpeg?,${PYTHON_USEDEP}]
+ dev-python/pillow[jpeg?,webp?,${PYTHON_USEDEP}]
dev-python/rencode[${PYTHON_USEDEP}]
dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
xdg? ( dev-python/pyxdg[${PYTHON_USEDEP}] )