summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-23 01:23:39 +0000
committerSam James <sam@gentoo.org>2022-03-23 01:23:39 +0000
commit9a11c5e701edf5c1497c584a891a6db135548f7e (patch)
treed939dbfe1025c005bf0b68a8bf2c458b492d72f2
parentmail-mta/exim: add subslot dep on hiredis (diff)
downloadgentoo-9a11c5e701edf5c1497c584a891a6db135548f7e.tar.gz
gentoo-9a11c5e701edf5c1497c584a891a6db135548f7e.tar.bz2
gentoo-9a11c5e701edf5c1497c584a891a6db135548f7e.zip
net-im/coturn: add subslot dep on hiredis
They break ABI liberally. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-im/coturn/coturn-4.5.2-r1.ebuild (renamed from net-im/coturn/coturn-4.5.2.ebuild)8
-rw-r--r--net-im/coturn/coturn-9999.ebuild8
2 files changed, 8 insertions, 8 deletions
diff --git a/net-im/coturn/coturn-4.5.2.ebuild b/net-im/coturn/coturn-4.5.2-r1.ebuild
index a183b67dbeae..37dde1c42c28 100644
--- a/net-im/coturn/coturn-4.5.2.ebuild
+++ b/net-im/coturn/coturn-4.5.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,11 +21,11 @@ SLOT="0"
IUSE="mongodb mysql postgres redis sqlite"
RDEPEND="acct-group/turnserver
acct-user/turnserver
- >dev-libs/libevent-2.1.8
+ >dev-libs/libevent-2.1.8:=
mongodb? ( dev-libs/mongo-c-driver )
- mysql? ( dev-db/mysql-connector-c )
+ mysql? ( dev-db/mysql-connector-c:= )
postgres? ( dev-db/postgresql:* )
- redis? ( dev-libs/hiredis )
+ redis? ( dev-libs/hiredis:= )
sqlite? ( dev-db/sqlite )"
DEPEND="${RDEPEND}"
diff --git a/net-im/coturn/coturn-9999.ebuild b/net-im/coturn/coturn-9999.ebuild
index 4830d0550d0b..4f65686782b4 100644
--- a/net-im/coturn/coturn-9999.ebuild
+++ b/net-im/coturn/coturn-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,11 +21,11 @@ SLOT="0"
IUSE="mongodb mysql postgres redis sqlite"
RDEPEND="acct-group/turnserver
acct-user/turnserver
- >dev-libs/libevent-2.1.8
+ >dev-libs/libevent-2.1.8:=
mongodb? ( dev-libs/mongo-c-driver )
- mysql? ( dev-db/mysql-connector-c )
+ mysql? ( dev-db/mysql-connector-c:= )
postgres? ( dev-db/postgresql:* )
- redis? ( dev-libs/hiredis )
+ redis? ( dev-libs/hiredis:= )
sqlite? ( dev-db/sqlite )"
DEPEND="${RDEPEND}"