summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-08-08 22:16:32 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-08-09 17:26:33 +0300
commit9a1ff45cf3cfd682fd6aa6ae72a83bb7cae37b60 (patch)
tree576a190ca015fbff75ed78e7c93e41eb355502f5
parentnet-dns/pdns: Version bump to 4.2.0_rc3 (diff)
downloadgentoo-9a1ff45c.tar.gz
gentoo-9a1ff45c.tar.bz2
gentoo-9a1ff45c.zip
net-misc/wol: bump to EAPI=7
Also corrected license and added myself as maintainer. Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Closes: https://github.com/gentoo/gentoo/pull/12646 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--net-misc/wol/metadata.xml27
-rw-r--r--net-misc/wol/wol-0.7.1-r2.ebuild22
2 files changed, 40 insertions, 9 deletions
diff --git a/net-misc/wol/metadata.xml b/net-misc/wol/metadata.xml
index 86ddb1d0fd53..b00b64532dec 100644
--- a/net-misc/wol/metadata.xml
+++ b/net-misc/wol/metadata.xml
@@ -1,13 +1,22 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <longdescription>
-wol implements Wake On LAN functionality in a small program. It wakes up hardware that is Magic Packet compliant.
-Consider you have a sleeping or turned-off computer and you want to remotely wake him up. Just type
-"wol MAC-ADDRESS" and the host wakes up (OK, it will boot ;-).
-</longdescription>
- <upstream>
- <remote-id type="sourceforge">ahh</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ This is wol, the Wake On Lan client.
+ It wakes up magic packet compliant machines such as boxes
+ with wake-on-lan ethernet-cards.
+ Some workstations provide SecureON which extends
+ wake-on-lan with a password. This feature is also provided by wol.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">ahh</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/net-misc/wol/wol-0.7.1-r2.ebuild b/net-misc/wol/wol-0.7.1-r2.ebuild
new file mode 100644
index 000000000000..7879c04f3c20
--- /dev/null
+++ b/net-misc/wol/wol-0.7.1-r2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Implements Wake On LAN (Magic Paket) functionality in a small program"
+HOMEPAGE="http://ahh.sourceforge.net/wol/"
+SRC_URI="mirror://sourceforge/ahh/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="nls"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-rpath
+ $(use_enable nls)
+ )
+
+ econf ${myeconfargs[@]}
+}