summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-02-02 08:22:50 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-02-02 08:22:50 +0100
commit9a31b29c748fd0d295818745a33c87c3cdfd404e (patch)
tree223102d39911837d76b9097a3aed62cdd6a44069
parentsys-libs/libcxx: depend on sys-devel/gdb[python] for tests (diff)
downloadgentoo-9a31b29c.tar.gz
gentoo-9a31b29c.tar.bz2
gentoo-9a31b29c.zip
dev-ml/topkg: 1.0.5 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-ml/topkg/Manifest1
-rw-r--r--dev-ml/topkg/topkg-1.0.5.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/topkg/Manifest b/dev-ml/topkg/Manifest
index ae0ad025d994..a5a2f2786db5 100644
--- a/dev-ml/topkg/Manifest
+++ b/dev-ml/topkg/Manifest
@@ -1 +1,2 @@
DIST topkg-1.0.3.tar.gz 122302 BLAKE2B c3c583fe6d9c6602c9eeae6ba76f0b8e1eda754cb2ffed8f6a9b51eeea53a2d16ad0af5bf3bf1f257233481efd1e7fecfca7185773dcb4258f6a0a8195aaf61f SHA512 b4f3393b142c5c2d71bb4a25f5af020831bd48ad5c354b68cf5a2df2044b534024f0568da93ad26ca383c97ba4277b4878dba7ce9267146f3805c67f52950cbf
+DIST topkg-1.0.5.tar.gz 123508 BLAKE2B b6090143659607fb65257adfc78f6c12782cf4cca99e5d997a2e324196cc19689b95b1412296feba410ce894d559e92d1f2c417ce46b441ad499a94264ffff99 SHA512 ea220df58ba3727281392b335377f9cea1cf1539ee86f2947faf1ccbcf36714fa40fbc06516867852d5992ca5840778467a02a0fe67369725da95eb442e4269a
diff --git a/dev-ml/topkg/topkg-1.0.5.ebuild b/dev-ml/topkg/topkg-1.0.5.ebuild
new file mode 100644
index 000000000000..85e68779db2c
--- /dev/null
+++ b/dev-ml/topkg/topkg-1.0.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="The transitory OCaml software packager"
+HOMEPAGE="http://erratique.ch/software/topkg https://github.com/dbuenzli/topkg"
+SRC_URI="https://github.com/dbuenzli/topkg/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="dev-ml/result:=
+ dev-ml/ocamlbuild:=
+ dev-ml/findlib:=
+ dev-lang/ocaml:=[ocamlopt?]"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ ocaml pkg/pkg.ml build --pkg-name ${PN} || die
+}
+
+src_install() {
+ # Can't use opam-installer here as it is an opam dep...
+ findlib_src_preinst
+
+ local nativelibs
+ if use ocamlopt; then
+ nativelibs=$(echo _build/src/${PN}*.cm{x,xa,xs,ti} _build/src/${PN}.a)
+ fi
+
+ ocamlfind install ${PN} _build/pkg/META _build/src/${PN}.mli _build/src/${PN}.cm{a,i} ${nativelibs} || die
+ dodoc CHANGES.md DEVEL.md README.md
+}