summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2022-08-19 10:45:30 -0500
committerBen Kohler <bkohler@gentoo.org>2022-08-19 10:46:49 -0500
commit9a40ecce263188d1f97857eeef2b47104ff53b67 (patch)
treeac183de5cc526f152072ce550d8ca7b0e4e5ed3d
parentapp-emacs/eldev: bump to 1.2 (diff)
downloadgentoo-9a40ecce263188d1f97857eeef2b47104ff53b67.tar.gz
gentoo-9a40ecce263188d1f97857eeef2b47104ff53b67.tar.bz2
gentoo-9a40ecce263188d1f97857eeef2b47104ff53b67.zip
dev-libs/libcpuid: new package, add 0.5.1
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
-rw-r--r--dev-libs/libcpuid/Manifest1
-rw-r--r--dev-libs/libcpuid/libcpuid-0.5.1.ebuild37
-rw-r--r--dev-libs/libcpuid/metadata.xml52
3 files changed, 90 insertions, 0 deletions
diff --git a/dev-libs/libcpuid/Manifest b/dev-libs/libcpuid/Manifest
new file mode 100644
index 000000000000..10355dba230b
--- /dev/null
+++ b/dev-libs/libcpuid/Manifest
@@ -0,0 +1 @@
+DIST libcpuid-0.5.1.tar.gz 166522 BLAKE2B 3471c11bbe4b0eaac7b00ac20a27556a95991f1b678269ae6f142a0fe2db066ebb756722ae2e76f95158742c93e29a35da6e735226d32b746034acae3ec2a5b7 SHA512 d725bc82e5aa2db69cea7b3590afbe11d6028cf4802fde8d498b4f1cc6d823e73d71b89a453d81bf996d97b36a71f6c00d0f6e8292b72f2be8a64b5d59c01861
diff --git a/dev-libs/libcpuid/libcpuid-0.5.1.ebuild b/dev-libs/libcpuid/libcpuid-0.5.1.ebuild
new file mode 100644
index 000000000000..5226c31da62b
--- /dev/null
+++ b/dev-libs/libcpuid/libcpuid-0.5.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=(python3_{9..11})
+
+inherit autotools python-any-r1
+
+DESCRIPTION="A small C library for x86 (and x86_64) CPU detection and feature extraction"
+HOMEPAGE="http://libcpuid.sourceforge.net/"
+SRC_URI="https://github.com/anrieff/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD-2"
+SLOT="0/15"
+KEYWORDS="~amd64"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf "$(use_enable static-libs static)"
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -delete || die
+}
diff --git a/dev-libs/libcpuid/metadata.xml b/dev-libs/libcpuid/metadata.xml
new file mode 100644
index 000000000000..fd09e47dd7c1
--- /dev/null
+++ b/dev-libs/libcpuid/metadata.xml
@@ -0,0 +1,52 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bkohler@gentoo.org</email>
+ <name>Ben Kohler</name>
+ </maintainer>
+ <longdescription>
+ <pkg>sys-libs/libcpuid</pkg> is a small C library for x86 (and x86_64)
+ CPU detection and feature extraction. Using it, you can:
+ - get the processor vendor, model, code name, etc.
+ - get information about CPU features such as: number of cores or
+ logical CPUs, cache sizes, CPU clock, etc.
+ - check if the processor implements a specific instruction set such as
+ the SSE2, 3DNow!, etc.
+ - execute the CPUID and RDTSC instructions.
+ - have this all in your commercial application, without getting into
+ trouble.
+ </longdescription>
+ <longdescription lang="fr">
+ <pkg>sys-libs/libcpuid</pkg> est une petite bibliothèque C pour la
+ détection de CPU x86 (et x86_64) et l'extraction de fonctions. En
+ l'utilisant, vous pouvez :
+ - obtenir le vendeur du processeur, le modèle, le nom de code, etc.
+ - obtenir des informations sur les caractéristiques du CPU telles que :
+ le nombre de cœurs ou d'unités logiques, les tailles des caches,
+ l'horloge CPU, etc.
+ - vérifier si le processeur implémente un jeu d'instructions spécifique
+ tel que l'instruction SSE2, 3DNow!, etc.
+ - exécuter les instructions CPUID et RDTSC.
+ - avoir tout cela dans votre application commerciale, sans avoir
+ d'ennuis.
+ </longdescription>
+ <slots>
+ <subslots>Reflect ABI compatibility for libcpuid.so</subslots>
+ </slots>
+ <slots lang="fr">
+ <subslots>
+ Reflétent la compatibilité de l'interface binaire-programme
+ (A.B.I.) de libcpuid.so
+ </subslots>
+ </slots>
+ <upstream>
+ <maintainer status="active">
+ <name>Veselin Georgiev</name>
+ </maintainer>
+ <changelog>https://raw.githubusercontent.com/anrieff/libcpuid/master/ChangeLog</changelog>
+ <doc>http://libcpuid.sourceforge.net/doxy/index.html</doc>
+ <bugs-to>https://github.com/anrieff/libcpuid/issues/</bugs-to>
+ <remote-id type="github">anrieff/libcpuid</remote-id>
+ </upstream>
+</pkgmetadata>