summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-05-05 14:46:48 -0700
committerMatt Turner <mattst88@gentoo.org>2022-05-05 14:47:31 -0700
commit9a5096948cc88d99212c52df377eb512b115c347 (patch)
tree40980e519dd1b59e1f948d32a6840bf4446715ca
parentapp-arch/lzlib: Remove old (diff)
downloadgentoo-9a5096948cc88d99212c52df377eb512b115c347.tar.gz
gentoo-9a5096948cc88d99212c52df377eb512b115c347.tar.bz2
gentoo-9a5096948cc88d99212c52df377eb512b115c347.zip
x11-libs/libnotify: Version bump to 0.7.12
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-libs/libnotify/Manifest1
-rw-r--r--x11-libs/libnotify/libnotify-0.7.12.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/x11-libs/libnotify/Manifest b/x11-libs/libnotify/Manifest
index ac48bb595cc4..3105fdf30ef2 100644
--- a/x11-libs/libnotify/Manifest
+++ b/x11-libs/libnotify/Manifest
@@ -1,3 +1,4 @@
DIST libnotify-0.7.11.tar.xz 101616 BLAKE2B 202456000bc092707e171dfd3ba06b46ac2bd7b222e2dd70540c17eda32639369cf9af2e275a49ea3a0859598d271cdd733b68ff66ed2c30d3c0987fa6de6a97 SHA512 1e96b88278fb5e941dc691a7bbb83ea7fbc46d7873e7e10d988cd44dd83fcd678956bf9e5cd2f5533cf316b2a23354161c80a5b12299eb119a3f5697e4935ed7
+DIST libnotify-0.7.12.tar.xz 102032 BLAKE2B fc0c0f377bf86cb9a7d3e080cf0aa23fa287a9199656d403624925208d86390e96f62d4c41f4b457efd403139f1bad52ff5fdd2c0cb3270c0abc82957b2634cf SHA512 1ddbdc2ea7ba653ea54169db9ed3d471f6e3421ef29e486c9b8d36837a655bcd613d0f07a8cf1253b87c42a2651e2f1634145622d8624d91e4223452deb99f1b
DIST libnotify-0.7.8.tar.xz 108436 BLAKE2B 0a73eabe58faca55e16774cda6f649ab3187bd73a1f87b538d5098f390571a6a34078883dbd2447731d6e4cae315d8286e9e8acc06e85590c8b05a693a83e7f7 SHA512 9973d7a1af5dd7cfbaa0d0d2c9e72a40df9d814967fde47e95763a69690cc4ed32ecf713d75f91f3dff99a693eff9dab963be124e0530ebf231d517a44e75e94
DIST libnotify-0.7.9.tar.xz 98148 BLAKE2B 4728d00a204cd1003e8171a54c23bb975c0477c245c1175558f27555763113ec8bd7abd7ef81f6bad2b98604efe436d843958e77473436e68560775804473383 SHA512 8a842b50777279efdb7d96a836a546c47decad158a4f03f7ffc818860d1f6276a657619e4f4a19a4e2f5ad55e0371c793420d50d802983700e8c342273b73874
diff --git a/x11-libs/libnotify/libnotify-0.7.12.ebuild b/x11-libs/libnotify/libnotify-0.7.12.ebuild
new file mode 100644
index 000000000000..b2f00994e9f7
--- /dev/null
+++ b/x11-libs/libnotify/libnotify-0.7.12.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson-multilib xdg-utils
+
+DESCRIPTION="A library for sending desktop notifications"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libnotify"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="gtk-doc +introspection test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.26:2[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-libs/gobject-introspection-common-1.32
+ dev-util/glib-utils
+ virtual/pkgconfig
+ app-text/docbook-xsl-ns-stylesheets
+ dev-libs/libxslt
+ gtk-doc? ( dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.1.2 )
+ test? ( x11-libs/gtk+:3[${MULTILIB_USEDEP}] )
+"
+IDEPEND="app-eselect/eselect-notify-send"
+PDEPEND="virtual/notification-daemon"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ $(meson_native_use_feature introspection)
+ $(meson_native_use_bool gtk-doc gtk_doc)
+ -Ddocbook_docs=disabled
+ )
+ meson_src_configure
+}
+
+multilib_src_install() {
+ meson_src_install
+
+ mv "${ED}"/usr/bin/{,libnotify-}notify-send || die #379941
+}
+
+pkg_postinst() {
+ eselect notify-send update ifunset
+}
+
+pkg_postrm() {
+ eselect notify-send update ifunset
+}