summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-29 20:05:33 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-29 20:17:06 +0200
commit9a5115aca188b52fa98d49d0ca553c1451713e70 (patch)
tree3d73c50cade55d713d987b7bac2ffe1c6eb25ced
parentdev-libs/libzia: Drop old (diff)
downloadgentoo-9a5115aca188b52fa98d49d0ca553c1451713e70.tar.gz
gentoo-9a5115aca188b52fa98d49d0ca553c1451713e70.tar.bz2
gentoo-9a5115aca188b52fa98d49d0ca553c1451713e70.zip
dev-python/qtconsole: Bump to 5.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/qtconsole/Manifest1
-rw-r--r--dev-python/qtconsole/qtconsole-5.1.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/qtconsole/Manifest b/dev-python/qtconsole/Manifest
index c412fb5377df..211e1cb782fd 100644
--- a/dev-python/qtconsole/Manifest
+++ b/dev-python/qtconsole/Manifest
@@ -1 +1,2 @@
DIST qtconsole-5.1.0.tar.gz 428856 BLAKE2B 4176c8add4fb949a82ce33fe9df598d2141c42dfa9ce57ae09ea201398df6ea54e00b890ad2b548b51e95f4dc0c7b2793640ced9b39b7adea910e3d2b90ec900 SHA512 50d2f1466d1fd5ebd33da1778f8271c5a328a61551f665e488c5c45326fabb4b431090d89b39c130a064b3c117cd24dc92e160c68c1eecf6647f2b662b01b2db
+DIST qtconsole-5.1.1.tar.gz 428840 BLAKE2B eb5f6dacf576133c07bc45a9f0fcfdfd041f72012d9564e288a40ac060a6843f6438c80836bcf2f35ffa1f575383bdffe347a498930fe96e2d99a1f1fbe3a032 SHA512 dd9f725fc6e55dea3910650c4c5641336ed1ed56e6eeaad91e6567743bc02fbd0ca567295c3c8897bb800df305ec0bf9f2d8caa8ad0099cdfa2d20c7ca96fbdc
diff --git a/dev-python/qtconsole/qtconsole-5.1.1.ebuild b/dev-python/qtconsole/qtconsole-5.1.1.ebuild
new file mode 100644
index 000000000000..e0891449a20e
--- /dev/null
+++ b/dev-python/qtconsole/qtconsole-5.1.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Qt-based console for Jupyter with support for rich media output"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-4.1.1[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ dev-python/QtPy[${PYTHON_USEDEP},gui,printsupport,svg]
+"
+BDEPEND="
+ test? (
+ dev-python/QtPy[${PYTHON_USEDEP},svg,testlib]
+ )
+"
+# required by the tests that are removed:
+# dev-python/flaky[${PYTHON_USEDEP}]
+# dev-python/pytest-qt[${PYTHON_USEDEP}]
+
+PDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+python_test() {
+ # TODO: these tests require virtx; however, running under virtx
+ # causes pytest to segv on exit (even though tests pass)
+ epytest --ignore qtconsole/tests/test_00_console_widget.py
+}