summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-06-04 07:37:55 +0200
committerHans de Graaff <graaff@gentoo.org>2019-06-04 07:37:55 +0200
commit9a51c881ce26f8bdee8edd330f862863df9c5495 (patch)
tree7dad022bbcec8edd79ed80add0d797eef71dd7de
parentdev-ruby/fuubar: cleanup (diff)
downloadgentoo-9a51c881ce26f8bdee8edd330f862863df9c5495.tar.gz
gentoo-9a51c881ce26f8bdee8edd330f862863df9c5495.tar.bz2
gentoo-9a51c881ce26f8bdee8edd330f862863df9c5495.zip
dev-ruby/fuubar: add 2.4.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
-rw-r--r--dev-ruby/fuubar/Manifest1
-rw-r--r--dev-ruby/fuubar/fuubar-2.4.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/fuubar/Manifest b/dev-ruby/fuubar/Manifest
index d1f0b538737b..f94dcae596f3 100644
--- a/dev-ruby/fuubar/Manifest
+++ b/dev-ruby/fuubar/Manifest
@@ -1 +1,2 @@
DIST fuubar-2.3.2.tar.gz 30383 BLAKE2B 4e43dcb5621bee74f0401573217e29d17f6f537dbfc86b2c23764f77224072b3efd15adacb9281681b4d16410db6cb2020918a42ee59132a1772b9c2bf3f43df SHA512 93e812f944153f3c4d147195777374584440ca779a5d45436052386a380308f471f6ba22906d823d4e9e2bad6bb72550d2a5eb7dc1535572e14866e9f05f6370
+DIST fuubar-2.4.0.tar.gz 31979 BLAKE2B ffc1d9a2b1a521650678e34e5597e1555e62115ce2e85b9695c241778d26bf5e9ef6b67dfa6903fca3842f0dfd576793180610ae66c61cbe4e9acf213b3bb215 SHA512 21623314bb5f025f3ca2e62c8ce630651ebea1ee1a60093ae3bb8da739f1f38d7faea333de74fbca94c5b12407e02fecd0cdc9ef1d403302cd9878727b02311f
diff --git a/dev-ruby/fuubar/fuubar-2.4.0.ebuild b/dev-ruby/fuubar/fuubar-2.4.0.ebuild
new file mode 100644
index 000000000000..738e61783c40
--- /dev/null
+++ b/dev-ruby/fuubar/fuubar-2.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Instafailing RSpec progress bar formatter"
+HOMEPAGE="https://github.com/thekompanee/fuubar"
+SRC_URI="https://github.com/thekompanee/fuubar/archive/releases/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="${PN}-releases-v${PV}"
+
+ruby_add_rdepend "dev-ruby/rspec:3 >=dev-ruby/ruby-progressbar-1.4:0"
+
+each_ruby_test() {
+ export CI=true
+ each_fakegem_test
+}