summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-05 13:56:25 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-05 13:56:56 +0100
commit9a67164e66131d09bf522372eaaeb5ceb3d93f4c (patch)
tree489e58376c787fa4384e799635143af7fec1353e
parentx11-wm/cwm: update upstream metadata (diff)
downloadgentoo-9a67164e66131d09bf522372eaaeb5ceb3d93f4c.tar.gz
gentoo-9a67164e66131d09bf522372eaaeb5ceb3d93f4c.tar.bz2
gentoo-9a67164e66131d09bf522372eaaeb5ceb3d93f4c.zip
dev-python/pyopengl: Fix running tests on systems without python[tk]
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyopengl/pyopengl-3.1.7-r1.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/dev-python/pyopengl/pyopengl-3.1.7-r1.ebuild b/dev-python/pyopengl/pyopengl-3.1.7-r1.ebuild
index c062ef4860ca..7dd53e7e560f 100644
--- a/dev-python/pyopengl/pyopengl-3.1.7-r1.ebuild
+++ b/dev-python/pyopengl/pyopengl-3.1.7-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -56,13 +56,14 @@ PATCHES=(
"${FILESDIR}/${P}-pypy3.patch"
)
-EPYTEST_DESELECT=(
- # unreliable memory counting test
- tests/test_vbo_memusage.py::test_sf_2980896
-)
-
python_test() {
- nonfatal epytest || die "Tests failed with ${EPYTHON}"
+ local EPYTEST_DESELECT=(
+ # unreliable memory counting test
+ tests/test_vbo_memusage.py::test_sf_2980896
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+
+ nonfatal epytest tests || die "Tests failed with ${EPYTHON}"
}
src_test() {