summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-05 23:40:56 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-05 23:46:45 +0200
commit9a6d11eb1dcb20dbdaaa4f6b65ba3f57c11c7f25 (patch)
treea61fa52c4b35cd34331aadb57607bdb0e883693d
parentdev-lang/python: Bump to 3.9.0 (diff)
downloadgentoo-9a6d11eb.tar.gz
gentoo-9a6d11eb.tar.bz2
gentoo-9a6d11eb.zip
dev-python/pytest-xprocess: Bump to 0.15.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-xprocess/Manifest1
-rw-r--r--dev-python/pytest-xprocess/pytest-xprocess-0.15.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pytest-xprocess/Manifest b/dev-python/pytest-xprocess/Manifest
index fac5b33c76e3..a4c00d52ca0a 100644
--- a/dev-python/pytest-xprocess/Manifest
+++ b/dev-python/pytest-xprocess/Manifest
@@ -1,2 +1,3 @@
DIST pytest-xprocess-0.13.1.tar.gz 10273 BLAKE2B 0c2a8bdf5e31543b32ada50f2bb5e1a09b45de820064807bf41321638d11d6b6fea28fd2a8c795e7bc6f7ac7370a3e78988e8aee318fad9df194fd3b06cce7cd SHA512 e0ab9e13d7f90ffca1bb3646e5789582806519ff5e665e13ed0db00896d799a7828b39e7657e947783d15ec1a961b33c1c981e39069dd298bf352826dbdc496f
DIST pytest-xprocess-0.14.0.tar.gz 13272 BLAKE2B 54a308b2d2783875c51b747c6c54fc7d8bf3542ea80590bdd51de0ee4ffeea73463793cfcfa8b8b75b45345b88ca4caebf3f5e45bc1de3fdc1649e0bdeebd72d SHA512 fc808d10f4adea1fba501178e30f82af575fa64fab9e3f44a73f1f1e809a09530be465d20be91ca0abb1fd270e9ebc397d64bccabfb3dc497b7b8f1123ef1fad
+DIST pytest-xprocess-0.15.0.tar.gz 13512 BLAKE2B 97ffef1e63f50ad2a1651f1791663f99e39c8fd8fc63427534efa5d60c9a4d856b7e036cd03faed73a1ba609716595ceeefe63604403a2bbd8a13407612a6402 SHA512 d2c7f6859b1696a8cb4445396376ce36bdcfdc8677fd97def716f240ae243c954f4110a3e500315a7f0c7f7ab7c337bf6749cbd1df3485db9fb95f42c2ffd181
diff --git a/dev-python/pytest-xprocess/pytest-xprocess-0.15.0.ebuild b/dev-python/pytest-xprocess/pytest-xprocess-0.15.0.ebuild
new file mode 100644
index 000000000000..d9f406cc465b
--- /dev/null
+++ b/dev-python/pytest-xprocess/pytest-xprocess-0.15.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage external processes across test runs"
+HOMEPAGE="https://pypi.org/project/pytest-xprocess/ https://github.com/pytest-dev/pytest-xprocess"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest