summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2024-03-10 19:27:18 +0100
committerGuilherme Amadio <amadio@gentoo.org>2024-03-10 19:27:18 +0100
commit9a6e608a7501a34518d16d5a3e81254a8bc308b8 (patch)
tree4c294c276c21ccd546b85fc3e82d8c84e4153fd8
parentnet-libs/davix: fix build with GCC 14, bug 919374 (diff)
downloadgentoo-9a6e608a7501a34518d16d5a3e81254a8bc308b8.tar.gz
gentoo-9a6e608a7501a34518d16d5a3e81254a8bc308b8.tar.bz2
gentoo-9a6e608a7501a34518d16d5a3e81254a8bc308b8.zip
net-libs/pacparser: add 1.4.3
Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
-rw-r--r--net-libs/pacparser/Manifest1
-rw-r--r--net-libs/pacparser/pacparser-1.4.3.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/net-libs/pacparser/Manifest b/net-libs/pacparser/Manifest
index bf811da3e8c4..9b5284ae8405 100644
--- a/net-libs/pacparser/Manifest
+++ b/net-libs/pacparser/Manifest
@@ -1,2 +1,3 @@
DIST pacparser-1.4.0.tar.gz 902919 BLAKE2B da29b34654764b1569d9d37648e4ccb608142becaf34c65cdf37b2bd81aa073b1945d840fb50aa7cb986687bbdc086c862a05bc421adb08d44e1add637b712ed SHA512 9574068dc4da3db27ddc1242cf98d98ebc7515864789e95b700cd2ce1433a7cff84160f1507976488fab7529839cabe9cf2aa16ddbefc0c83009fa6c0d2ad6b3
DIST pacparser-1.4.2.tar.gz 903425 BLAKE2B 6b46fd87487feacb3915ddd3705eb60f795257adc5361fddbfc550c537471276f464f367b57124efc49f57666f232c297df763f2adea34d7642bd1e3271f47b4 SHA512 65d12421ee79a969b867d7dcec1527ac9b2596c25f6be2502742ba1b3788f05afeed2fcd5406dfb39485d1d56ef161684acabe6a95008725385c3c5336f331b1
+DIST pacparser-1.4.3.tar.gz 905231 BLAKE2B bffe42154a8de9798c4c7b986e5797c19cbb103ed2977545014278f63a770c7cd9ed6b7fc6a9fff96514a71457b9dbc35104a51d9e5e331e2d19f3baeb86e621 SHA512 cc0d6c0a7b1fd9d55dece6c4ad80711d3d1055a0cde120dbb6e8274508631b325e7d876545b40ca05cefc6dce15aa1476e5b2936527e3183ad86114e4cd661a5
diff --git a/net-libs/pacparser/pacparser-1.4.3.ebuild b/net-libs/pacparser/pacparser-1.4.3.ebuild
new file mode 100644
index 000000000000..87e64cf6c25f
--- /dev/null
+++ b/net-libs/pacparser/pacparser-1.4.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit python-r1 toolchain-funcs
+
+DESCRIPTION="Library to parse proxy auto-config files"
+HOMEPAGE="http://pacparser.manugarg.com/"
+SRC_URI="https://github.com/manugarg/${PN}/archive/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc python"
+
+DEPEND="python? ( ${PYTHON_DEPS} )"
+RDEPEND="${DEPEND}"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# spidermonkey-1.7.0 is bundled
+# tested unbundling with spidermonkey-1.8* and 1.7
+# and got many failures: unbundling not worth it.
+
+src_prepare() {
+ default
+
+ sed -e 's/^SMCFLAGS.*/SMCFLAGS = -DHAVE_VA_COPY -DVA_COPY=va_copy -DHAVE_VA_LIST_AS_ARRAY/' \
+ -i src/Makefile || die
+ sed -e '/CC = gcc/d' \
+ -i src/spidermonkey/js/src/config/Linux_All.mk || die
+
+ export NO_INTERNET=yes
+ export VERSION="${PV}"
+ tc-export CC AR RANLIB
+}
+
+src_compile() {
+ # Upstream parallel compilation bug, do that first to work around
+ emake -C src -j1
+ use python && python_foreach_impl emake -C src pymod
+}
+
+src_install() {
+ emake \
+ LIB_PREFIX="${ED}/usr/$(get_libdir)" \
+ DOC_PREFIX="${ED}/usr/share/doc/${PF}" \
+ BIN_PREFIX="${ED}"/usr/bin \
+ INC_PREFIX="${ED}"/usr/include \
+ MAN_PREFIX="${ED}"/usr/share/man \
+ -C src install
+ dodoc README.md
+
+ if use python; then
+ python_foreach_impl emake DESTDIR="${D}" -C src install-pymod
+ python_foreach_impl python_optimize
+ fi
+
+ if use doc; then
+ docompress -x /usr/share/doc/${PF}/{html,examples}
+ else
+ rm -r "${ED}"/usr/share/doc/${PF}/{html,examples} || die
+ fi
+}