summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2023-07-30 19:46:49 +0800
committerBenda Xu <heroxbd@gentoo.org>2023-07-30 19:52:29 +0800
commit9a6ec44dcc26a52c273ac0a2d0826052c0607c24 (patch)
tree9d64163a539485654cbf64da517ee943755df4f2
parentapp-forensics/foremost: simplify the musl patch. (diff)
downloadgentoo-9a6ec44d.tar.gz
gentoo-9a6ec44d.tar.bz2
gentoo-9a6ec44d.zip
app-forensics/foremost: support Prefix and keyword {x64,arm64}-macos
Signed-off-by: Benda Xu <heroxbd@gentoo.org>
-rw-r--r--app-forensics/foremost/foremost-1.5.7-r4.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-forensics/foremost/foremost-1.5.7-r4.ebuild b/app-forensics/foremost/foremost-1.5.7-r4.ebuild
new file mode 100644
index 000000000000..7efec700c421
--- /dev/null
+++ b/app-forensics/foremost/foremost-1.5.7-r4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs prefix
+
+DESCRIPTION="Console program to recover files based on their headers and footers"
+HOMEPAGE="http://foremost.sourceforge.net/"
+#SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+# starting to hate sf.net ...
+SRC_URI="http://foremost.sourceforge.net/pkg/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~arm64-macos ~x64-macos"
+IUSE=""
+
+src_prepare() {
+ PATCHES=(
+ "${FILESDIR}/${PN}-1.4-config-location.patch"
+ "${FILESDIR}/${PN}-1.5.7-format-security.patch" # bug 521038
+ "${FILESDIR}/${PN}-1.5.7-set-but-unused.patch" # bug 706886
+ "${FILESDIR}/${PN}-1.5.7-fno-common.patch" # bug 722196
+ "${FILESDIR}/${PN}-1.5.7-musl.patch" # bug 830473
+ )
+
+ default
+ hprefixify config.c
+}
+
+src_compile() {
+ emake \
+ RAW_FLAGS="${CFLAGS} -Wall ${LDFLAGS}" \
+ RAW_CC="$(tc-getCC) -DVERSION=\\\"${PV}\\\"" \
+ CONF=/etc
+}
+
+src_install() {
+ dobin foremost
+ gunzip foremost.8.gz || die
+ doman foremost.8
+ insinto /etc
+ doins foremost.conf
+ dodoc README CHANGES
+}