summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Persson Forsberg <cat@catcream.org>2022-08-18 01:18:09 +0200
committerSam James <sam@gentoo.org>2022-08-23 06:23:57 +0100
commit9a77abf00e3d75523e999e9dae30aed6e30409aa (patch)
treee220b7ada158c63ccc501b7d893db579365e29c8
parentapp-editor/vim: provide configure defaults when cross compiling (diff)
downloadgentoo-9a77abf0.tar.gz
gentoo-9a77abf0.tar.bz2
gentoo-9a77abf0.zip
app-editor/vim-core: provide configure defaults when cross compiling
Signed-off-by: Alfred Persson Forsberg <cat@catcream.org> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-editors/vim-core/vim-core-9.0.0099.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/app-editors/vim-core/vim-core-9.0.0099.ebuild b/app-editors/vim-core/vim-core-9.0.0099.ebuild
index 8bea948c71c7..8249383faac5 100644
--- a/app-editors/vim-core/vim-core-9.0.0099.ebuild
+++ b/app-editors/vim-core/vim-core-9.0.0099.ebuild
@@ -148,6 +148,14 @@ src_configure() {
# Keep Gentoo Prefix env contained within the EPREFIX
use prefix && myconf+=( --without-local-dir )
+ if tc-is-cross-compiler ; then
+ export vim_cv_getcwd_broken=no \
+ vim_cv_memmove_handles_overlap=yes \
+ vim_cv_stat_ignores_slash=yes \
+ vim_cv_terminfo=yes \
+ vim_cv_toupper_broken=no
+ fi
+
econf "${myconf[@]}"
}