summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-07-22 09:07:01 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-07-22 09:25:36 +0200
commit9a7c8363e700e7ff43ef94dfa2ec2d32b5dc0446 (patch)
treeb1917e38bdcd885b3ee73787b2148a9202032b0a
parentdev-python/django-auth-ldap: Bump to 3.0.0 (diff)
downloadgentoo-9a7c8363.tar.gz
gentoo-9a7c8363.tar.bz2
gentoo-9a7c8363.zip
app-text/lesspipe: Bump to version 1.86
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--app-text/lesspipe/Manifest1
-rw-r--r--app-text/lesspipe/lesspipe-1.86.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-text/lesspipe/Manifest b/app-text/lesspipe/Manifest
index f6fac7d4bba5..047709596abd 100644
--- a/app-text/lesspipe/Manifest
+++ b/app-text/lesspipe/Manifest
@@ -1 +1,2 @@
DIST lesspipe-1.85.tar.gz 120568 BLAKE2B d2c00f4121dc1bbed6b82220dac038068bbff87c732385399542cb212d4664c74d018db07829f90c38e938cb8623a443888c74b0d003fff725d0ddf207d8109e SHA512 420d087b9fc9783b9404855e4656b88c10852502bd2f1931978b7dc7ff15eba1a375b217184480f9b341322c12e7336d0861ba9c2f673f2b2a7fb340a381f5b2
+DIST lesspipe-1.86.tar.gz 120910 BLAKE2B 1065bd95707991380cee8b1be917ae66a6537fdd721e9ec0c326b1ce3358ae518dd28902505967fc086e57e9d3e603e27a328f38c79ae38fe70e5e2a8306b59a SHA512 88a890b91ff3d889f32f23d85d76ef96947e8f1175d54d4301e8891587e87bf1c0a147f1fd5391e52badf4ee31229d337b97c5d5e5f74f4dde966eb93294cfb2
diff --git a/app-text/lesspipe/lesspipe-1.86.ebuild b/app-text/lesspipe/lesspipe-1.86.ebuild
new file mode 100644
index 000000000000..6ebe2f17d7a8
--- /dev/null
+++ b/app-text/lesspipe/lesspipe-1.86.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="a preprocessor for less"
+HOMEPAGE="https://github.com/wofr06/lesspipe"
+SRC_URI="https://github.com/wofr06/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Tests are broken in 1.84, 1.85.
+# Please check again on bumps!
+# bug #734896
+RESTRICT="test"
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ !<sys-apps/less-483-r1"
+
+src_configure() {
+ # Not an autoconf script.
+ ./configure --fixed || die
+}
+
+src_compile() {
+ # Nothing to build.
+ :
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" install
+ einstalldocs
+}
+
+pkg_preinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "This package installs 'lesspipe.sh' which is distinct from 'lesspipe'."
+ elog "The latter is the Gentoo-specific version. Make sure to update your"
+ elog "LESSOPEN environment variable if you wish to use this copy."
+ fi
+}