summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-09-05 01:44:50 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-09-05 01:46:34 +0200
commit9a7eb10d34d46677417174a00d7f879d986817f3 (patch)
tree4242d6989561dcf02ffda88b68c30ec7097a6fcc
parentacct-group/nslcd: Add metadata.xml (diff)
downloadgentoo-9a7eb10d.tar.gz
gentoo-9a7eb10d.tar.bz2
gentoo-9a7eb10d.zip
net-p2p/torrentinfo: add Python 3.9 support
Package-Manager: Portage-3.0.3, Repoman-2.3.23 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
-rw-r--r--net-p2p/torrentinfo/torrentinfo-1.8.6-r2.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/net-p2p/torrentinfo/torrentinfo-1.8.6-r2.ebuild b/net-p2p/torrentinfo/torrentinfo-1.8.6-r2.ebuild
index 56e97bef6ea9..7c4fc84190c9 100644
--- a/net-p2p/torrentinfo/torrentinfo-1.8.6-r2.ebuild
+++ b/net-p2p/torrentinfo/torrentinfo-1.8.6-r2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
# The package uses distutils
DISTUTILS_USE_SETUPTOOLS=no
@@ -18,12 +18,12 @@ KEYWORDS="amd64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
-BDEPEND="
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
+BDEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
PATCHES=( "${FILESDIR}/${P}-fix-tests.patch" )
+# distutils_enable_tests nose doesn't work here,
+# probably because the test file has a non-standard name
python_test() {
nosetests test/tests.py || die "tests failed with ${EPYTHON}"
}