summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-03-01 09:30:58 +0100
committerHans de Graaff <graaff@gentoo.org>2020-03-01 09:30:58 +0100
commit9a7f524ff4060e48f10b7c3cec3fc77be0f29399 (patch)
treefa595eb981cce2e1047264475b137743ab2ace55
parentdev-ruby/sinatra: add 2.0.8.1 (diff)
downloadgentoo-9a7f524f.tar.gz
gentoo-9a7f524f.tar.bz2
gentoo-9a7f524f.zip
sci-geosciences/viking: fix compilation with no-common
Closes: https://bugs.gentoo.org/710904 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--sci-geosciences/viking/files/viking-1.7-no-common.patch13
-rw-r--r--sci-geosciences/viking/viking-1.7-r1.ebuild93
2 files changed, 106 insertions, 0 deletions
diff --git a/sci-geosciences/viking/files/viking-1.7-no-common.patch b/sci-geosciences/viking/files/viking-1.7-no-common.patch
new file mode 100644
index 000000000000..bf49709dc865
--- /dev/null
+++ b/sci-geosciences/viking/files/viking-1.7-no-common.patch
@@ -0,0 +1,13 @@
+--- a/src/babel.h.orig 2020-02-06 07:22:12.924565811 +0100
++++ b/src/babel.h 2020-02-06 07:22:25.092329302 +0100
+@@ -109,8 +109,8 @@
+ gchar *label;
+ } BabelFile;
+
+-GList *a_babel_file_list;
+-GList *a_babel_device_list;
++extern GList *a_babel_file_list;
++extern GList *a_babel_device_list;
+
+ void a_babel_foreach_file_with_mode (BabelMode mode, GFunc func, gpointer user_data);
+ void a_babel_foreach_file_read_any (GFunc func, gpointer user_data);
diff --git a/sci-geosciences/viking/viking-1.7-r1.ebuild b/sci-geosciences/viking/viking-1.7-r1.ebuild
new file mode 100644
index 000000000000..6649edf1b58a
--- /dev/null
+++ b/sci-geosciences/viking/viking-1.7-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="GPS data editor and analyzer"
+HOMEPAGE="https://sourceforge.net/projects/viking/"
+IUSE="doc +exif libexif geoclue gps +magic mapnik nls oauth sqlite"
+SRC_URI="
+ mirror://sourceforge/${PN}/${P}.tar.bz2
+ doc? ( mirror://sourceforge/${PN}/${PN}.pdf )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+COMMONDEPEND="
+ app-arch/bzip2
+ >=dev-tcltk/expect-5.45.4
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nettle
+ net-misc/curl
+ sys-libs/zlib
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ geoclue? ( app-misc/geoclue:2.0 )
+ gps? ( >=sci-geosciences/gpsd-2.96 )
+ exif? ( libexif? ( media-libs/libexif ) !libexif? ( media-libs/gexiv2 ) )
+ magic? ( sys-apps/file )
+ mapnik? ( sci-geosciences/mapnik )
+ oauth? ( net-libs/liboauth )
+ sqlite? ( dev-db/sqlite:3 )
+"
+RDEPEND="${COMMONDEPEND}
+ sci-geosciences/gpsbabel
+"
+DEPEND="${COMMONDEPEND}
+ app-text/gnome-doc-utils
+ dev-util/intltool
+ dev-util/gtk-doc-am
+ app-text/rarian
+ dev-libs/libxslt
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+PATCHES=( "${FILESDIR}/${P}-no-common.patch" )
+
+src_configure() {
+ econf \
+ --disable-deprecations \
+ --with-libcurl \
+ --with-expat \
+ --enable-google \
+ --enable-nettle \
+ --enable-terraserver \
+ --enable-expedia \
+ --enable-openstreetmap \
+ --enable-bluemarble \
+ --enable-geonames \
+ --enable-geocaches \
+ --disable-dem24k \
+ $(use_enable exif geotag) \
+ $(use_with libexif ) \
+ $(use_enable geoclue) \
+ $(use_enable gps realtime-gps-tracking) \
+ $(use_enable magic) \
+ $(use_enable mapnik) \
+ $(use_enable nls) \
+ $(use_enable oauth) \
+ $(use_enable sqlite mbtiles )
+}
+
+src_install() {
+ default
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins "${DISTDIR}"/${PN}.pdf
+ fi
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}