summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-08-31 14:37:44 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-08-31 14:38:12 +0200
commit9a9098775746c7c1703fa1188eb8c291c0d46f75 (patch)
tree5e596c5fd62d52b25823e99f6c1f2499a61e4477
parentdev-python/numpydoc: enable py3.11 (diff)
downloadgentoo-9a909877.tar.gz
gentoo-9a909877.tar.bz2
gentoo-9a909877.zip
dev-python/sphinxcontrib-bibtex: add 2.5.0
Closes: https://bugs.gentoo.org/866015 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/sphinxcontrib-bibtex/Manifest1
-rw-r--r--dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.5.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-bibtex/Manifest b/dev-python/sphinxcontrib-bibtex/Manifest
index 6b2af5ac532d..3d1cbb9616bd 100644
--- a/dev-python/sphinxcontrib-bibtex/Manifest
+++ b/dev-python/sphinxcontrib-bibtex/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib-bibtex-2.4.2.tar.gz 284061 BLAKE2B 06d9a868da621cca522c45998ce5f28a5aafc501127760c494e9e796d807800cccf3ee0cace7f4b824a00a76e8dd80e77d0ac5e037f2eaebbeec2ce4ea2ead70 SHA512 52d47bf0a20ef13f29b712bbe66cbcb98bd9531b8032a847375ff23180368decc3f89c2323b9ccff77c9bc9fdada63c521a81da6b701533973fcf627c2672e82
+DIST sphinxcontrib-bibtex-2.5.0.tar.gz 113310 BLAKE2B 5bd39fccf33897bbbf8359a09f07a6e7146d4fb3c1ccb63ad96d3980cc4a256e0b9b37bbf6ceadf65eb01937741934e1f30841587eb6246b50774c81e8428998 SHA512 c99b4bf8cbc73e94e7e4486b4cb58de0dc928079b320ee7d7a473ee27b7f1e349a4765a30059aadc3fb0c6161940c6f2eaf7afdf5ac1c64ba73ed80fba5b5e45
diff --git a/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.5.0.ebuild b/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.5.0.ebuild
new file mode 100644
index 000000000000..6ba25e18e884
--- /dev/null
+++ b/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.5.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extensions for BibTeX style citations"
+HOMEPAGE="https://github.com/mcmtroffaes/sphinxcontrib-bibtex"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/docutils-0.8[${PYTHON_USEDEP}]
+ >=dev-python/importlib_metadata-3.6[${PYTHON_USEDEP}]
+ >=dev-python/pybtex-0.24[${PYTHON_USEDEP}]
+ >=dev-python/pybtex-docutils-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-2.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/numpydoc[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # rinoh not packaged
+ test/test_citation_rinoh.py::test_citation_rinoh
+ test/test_citation_rinoh.py::test_citation_rinoh_multidoc
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ distutils_write_namespace sphinxcontrib
+ epytest
+}