summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2020-07-17 20:46:53 +1000
committerMark Wright <gienah@gentoo.org>2020-07-17 20:48:00 +1000
commit9a942b9f13c331d304201d35fe1a0f78491291b3 (patch)
tree691b0b1fb12a19d11c3a978d54f463439e971dc6
parentvirtual/rust: arm64 stable (bug #732798) (diff)
downloadgentoo-9a942b9f.tar.gz
gentoo-9a942b9f.tar.bz2
gentoo-9a942b9f.zip
sci-mathematics/rstudio: Bump to rstudio-1.3.1056
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Mark Wright <gienah@gentoo.org>
-rw-r--r--sci-mathematics/rstudio/Manifest1
-rw-r--r--sci-mathematics/rstudio/files/rstudio-1.3.1056-R-4.0.0.patch58
-rw-r--r--sci-mathematics/rstudio/files/rstudio-1.3.1056-boost-1.74.0.patch30
-rw-r--r--sci-mathematics/rstudio/rstudio-1.3.1056.ebuild232
4 files changed, 321 insertions, 0 deletions
diff --git a/sci-mathematics/rstudio/Manifest b/sci-mathematics/rstudio/Manifest
index 063f62802551..686f27d6dda7 100644
--- a/sci-mathematics/rstudio/Manifest
+++ b/sci-mathematics/rstudio/Manifest
@@ -1,4 +1,5 @@
DIST core-dictionaries.zip 876339 BLAKE2B f29afcbf5a7f8ec635e5a5b248d978af286d18488f54c9a09a2b95fde19b796e4473e5846402a46dd24b71c6e4167512539aaa32ab6d99713d500a80aaf46796 SHA512 9c5830cc9fed575e223f1c61f02e48c5aea6801bb0cd2586f02437c17fdffdb1d36c396d5a8ecbe02ba01196e73458304345b1f6b92c052bc7a7d05961fac2c9
DIST rstudio-1.2.5033.tar.gz 20456976 BLAKE2B 3cbca6a5180690104dddf1456168bd38708d4152ed9b7a167035dd66e270aeb6405169d34461cbd899738be1872607e3f3b6f81ff0b3c9e6a9ed965a889b1393 SHA512 3569d4fed342275a9905c87e4f97be63b6391d2c37f75397e06201a7c31f80d94799214f51ff8e57d458ef18d5e54afe1ec8a7c56ac05ed8b8225ecca72d1daf
DIST rstudio-1.2.5042.tar.gz 20456999 BLAKE2B 3251ab2511daefefa395256fedb273ecc36dbc8118457474e3647f7616baea91301e597896582ad4b191195fc7baf17645c4c25b9a957a0c17a6251151b1dd87 SHA512 e09f2360abecde0c16e240e6838efb270a355bec3d3982ffde2b01b32b21e9281fef465734edbfeb5e05375529cc7f06d5b5d41304f367982f53ae7ad98e20f9
+DIST rstudio-1.3.1056.tar.gz 89584544 BLAKE2B 0e758ad97f9faa2d3932a49dafd92bc21199a5c0a20e2d8480267ebbb7cd11dc38596b4bb697e04add7bfe6b126f7b2ae6675040a0ac8caca5a5cf737f5ad6eb SHA512 8a9077c2ae021e0cf4cca41b374a50534087b35fd2c1e4b18bdd5ba3672e1ab275046e483ec8a3aba729a8e39f961149fb03a053ea005d8a32873b51201baca2
DIST rstudio-1.3.959.tar.gz 89639419 BLAKE2B d45b2c1b0e426ddb5a945e59a8127ddfd47f6230ef0929639c4b525382ae57437a273df6ade85cfbf3a29911cf0158ee2e0808bfa94e783d70d4615f6c228f31 SHA512 e5d8bfe16011790ff4723c731043f44070d8fe48f85c5a9ab8389c9a2b7a1d3813e9362063ec4c6a6ca3b0a0857e2190481cbb74191650a129c0d2e10b342fac
diff --git a/sci-mathematics/rstudio/files/rstudio-1.3.1056-R-4.0.0.patch b/sci-mathematics/rstudio/files/rstudio-1.3.1056-R-4.0.0.patch
new file mode 100644
index 000000000000..662089e93a01
--- /dev/null
+++ b/sci-mathematics/rstudio/files/rstudio-1.3.1056-R-4.0.0.patch
@@ -0,0 +1,58 @@
+From 71b1a935762efd24a79de193662450de5a89f67e Mon Sep 17 00:00:00 2001
+From: Jonathan McPherson <jonathan@rstudio.com>
+Date: Tue, 14 Jan 2020 12:53:20 -0800
+Subject: [PATCH] use R_NoSave over R_Slave for R 4.0+
+
+---
+ src/cpp/r/CMakeLists.txt | 12 ++++++++++++
+ src/cpp/r/config.h.in | 8 +++++++-
+ src/cpp/r/session/REmbeddedPosix.cpp | 20 ++++++++++++++------
+ 3 files changed, 33 insertions(+), 7 deletions(-)
+
+diff --git a/src/cpp/r/CMakeLists.txt b/src/cpp/r/CMakeLists.txt
+index 6984ae309c..29784b8b67 100644
+--- a/src/cpp/r/CMakeLists.txt
++++ b/src/cpp/r/CMakeLists.txt
+@@ -15,6 +15,18 @@
+
+ project (R)
+
++# find the version of R in play
++find_package(LibR REQUIRED)
++execute_process(
++ COMMAND "${LIBR_EXECUTABLE}" "--vanilla" "--slave" "-e" "cat(as.character(getRversion()))"
++ OUTPUT_VARIABLE LIBR_VERSION)
++
++# parse and save the R version to a variable
++string(REPLACE "." ";" R_VERSION_LIST "${LIBR_VERSION}")
++list(GET R_VERSION_LIST 0 R_VERSION_MAJOR)
++list(GET R_VERSION_LIST 1 R_VERSION_MINOR)
++list(GET R_VERSION_LIST 2 R_VERSION_PATCH)
++
+ # include files
+ file(GLOB_RECURSE R_HEADER_FILES "*.h*")
+
+diff --git a/src/cpp/r/config.h.in b/src/cpp/r/config.h.in
+index 6ba67c8e09..00bc8b6191 100644
+--- a/src/cpp/r/config.h.in
++++ b/src/cpp/r/config.h.in
+@@ -1,7 +1,7 @@
+ /*
+ * config.h.in
+ *
+- * Copyright (C) 2009-12 by RStudio, PBC
++ * Copyright (C) 2009-20 by RStudio, Inc.
+ *
+ * Unless you have received this program directly from RStudio pursuant
+ * to the terms of a commercial license agreement with RStudio, then
+@@ -16,4 +16,10 @@
+
+ #cmakedefine PANGO_CAIRO_FOUND
+
++// Important: These variables represent the version of R found during
++// compile/link time, NOT the version of R present at runtime.
++#define R_VERSION_MAJOR ${R_VERSION_MAJOR}
++#define R_VERSION_MINOR ${R_VERSION_MINOR}
++#define R_VERSION_PATCH ${R_VERSION_PATCH}
++
+
diff --git a/sci-mathematics/rstudio/files/rstudio-1.3.1056-boost-1.74.0.patch b/sci-mathematics/rstudio/files/rstudio-1.3.1056-boost-1.74.0.patch
new file mode 100644
index 000000000000..2fde3119e2a4
--- /dev/null
+++ b/sci-mathematics/rstudio/files/rstudio-1.3.1056-boost-1.74.0.patch
@@ -0,0 +1,30 @@
+--- rstudio-1.3.1056-orig/src/cpp/core/file_lock/FileLock.cpp 2020-07-08 08:25:03.000000000 +1000
++++ rstudio-1.3.1056/src/cpp/core/file_lock/FileLock.cpp 2020-07-17 18:01:57.016882590 +1000
+@@ -26,6 +26,7 @@
+ #include <core/system/Environment.hpp>
+
+ #include <boost/algorithm/string.hpp>
++#include <boost/bind.hpp>
+
+ // borrowed from SessionConstants.hpp
+ #define kRStudioSessionRoute "RSTUDIO_SESSION_ROUTE"
+--- rstudio-1.3.1056-orig/src/cpp/core/HtmlUtils.cpp 2020-07-08 08:25:03.000000000 +1000
++++ rstudio-1.3.1056/src/cpp/core/HtmlUtils.cpp 2020-07-17 18:01:58.129886387 +1000
+@@ -19,6 +19,7 @@
+
+ #include <boost/format.hpp>
+ #include <boost/algorithm/string/predicate.hpp>
++#include <boost/bind.hpp>
+
+ #include <core/Base64.hpp>
+ #include <core/FileSerializer.hpp>
+--- rstudio-1.3.1056-orig/src/cpp/r/session/RStdCallbacks.cpp 2020-07-08 08:25:03.000000000 +1000
++++ rstudio-1.3.1056/src/cpp/r/session/RStdCallbacks.cpp 2020-07-17 18:32:09.044071640 +1000
+@@ -19,6 +19,7 @@
+
+ #include <boost/function.hpp>
+ #include <boost/regex.hpp>
++#include <boost/bind.hpp>
+
+ #include <r/RExec.hpp>
+ #include <r/ROptions.hpp>
diff --git a/sci-mathematics/rstudio/rstudio-1.3.1056.ebuild b/sci-mathematics/rstudio/rstudio-1.3.1056.ebuild
new file mode 100644
index 000000000000..49d75885be5f
--- /dev/null
+++ b/sci-mathematics/rstudio/rstudio-1.3.1056.ebuild
@@ -0,0 +1,232 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils cmake pam xdg-utils java-pkg-2 java-ant-2 pax-utils prefix qmake-utils vcs-clean
+
+# TODO
+# * use dict from tree, linguas
+# * do src_test (use junit from tree?)
+
+GIN_VER=2.1.2
+# grep 'PANDOC_VERSION=' dependencies/common/install-pandoc
+# It should be PANDOC_VER=2.7.3 however >=app-text/pandoc-2.7.3 is not yet in portage
+PANDOC_VER=1.19.2.1
+# grep -5 QT_CANDIDATES src/cpp/desktop/CMakeLists.txt
+QT_VER=5.12.6
+QT_SLOT=5
+
+DESCRIPTION="IDE for the R language"
+HOMEPAGE="
+ http://www.rstudio.org
+ https://github.com/rstudio/rstudio/"
+SRC_URI="
+ https://github.com/rstudio/rstudio/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://s3.amazonaws.com/rstudio-dictionaries/core-dictionaries.zip
+"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="dedicated libressl server"
+
+RDEPEND="
+ >=app-text/pandoc-${PANDOC_VER}
+ dev-java/aopalliance:1
+ dev-java/gin:2.1
+ dev-java/javax-inject
+ =dev-java/validation-api-1.0*:1.0[source]
+ dev-haskell/pandoc-citeproc
+ dev-lang/R
+ dev-libs/boost:=
+ >=dev-libs/mathjax-2.7.4
+ sys-apps/util-linux
+ sys-devel/clang:*
+ sys-libs/zlib
+ >=virtual/jre-1.8:=
+ x11-libs/pango
+ !dedicated? (
+ >=dev-qt/qtcore-${QT_VER}:${QT_SLOT}
+ >=dev-qt/qtdeclarative-${QT_VER}:${QT_SLOT}
+ >=dev-qt/qtdbus-${QT_VER}:${QT_SLOT}
+ >=dev-qt/qtgui-${QT_VER}:${QT_SLOT}
+ >=dev-qt/qtnetwork-${QT_VER}:${QT_SLOT}
+ >=dev-qt/qtopengl-${QT_VER}:${QT_SLOT}
+ >=dev-qt/qtpositioning-${QT_VER}:${QT_SLOT}
+ >=dev-qt/qtprintsupport-${QT_VER}:${QT_SLOT}
+ >=dev-qt/qtsingleapplication-2.6.1_p20150629[X,qt5(+)]
+ >=dev-qt/qtsensors-${QT_VER}:${QT_SLOT}
+ >=dev-qt/qtsql-${QT_VER}:${QT_SLOT}
+ >=dev-qt/qtsvg-${QT_VER}:${QT_SLOT}
+ >=dev-qt/qtwebchannel-${QT_VER}:${QT_SLOT}
+ >=dev-qt/qtwebengine-${QT_VER}:${QT_SLOT}[widgets]
+ >=dev-qt/qtwidgets-${QT_VER}:${QT_SLOT}
+ >=dev-qt/qtxml-${QT_VER}:${QT_SLOT}
+ >=dev-qt/qtxmlpatterns-${QT_VER}:${QT_SLOT}
+ server? ( sys-libs/pam )
+ )
+ dedicated? ( sys-libs/pam )
+ dedicated? (
+ sys-libs/pam
+ acct-user/rstudio-server
+ acct-group/rstudio-server
+ )
+ server? (
+ acct-user/rstudio-server
+ acct-group/rstudio-server
+ )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-java/ant-core
+ >=virtual/jdk-1.8:=
+ virtual/pkgconfig"
+# test? ( dev-java/junit:4 )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.959-prefs.patch
+ "${FILESDIR}"/${PN}-1.3.959-paths.patch
+ "${FILESDIR}"/${PN}-1.3.959-pandoc-mathjax.patch
+ "${FILESDIR}"/${PN}-1.2.1335-linker_flags.patch
+ "${FILESDIR}"/${PN}-1.3.959-qtsingleapplication.patch
+ "${FILESDIR}"/${PN}-1.0.44-systemd.patch
+ "${FILESDIR}"/${PN}-1.3.959-core.patch
+ "${FILESDIR}"/${PN}-1.2.5042-boost-1.73.0.patch
+ "${FILESDIR}"/${PN}-1.3.1056-R-4.0.0.patch
+ "${FILESDIR}"/${PN}-1.3.1056-boost-1.74.0.patch
+)
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}" || die
+ mkdir -p dependencies/common/dictionaries
+ unzip -qd dependencies/common/dictionaries \
+ "${DISTDIR}"/core-dictionaries.zip || die
+}
+
+src_prepare() {
+ cmake_src_prepare
+ java-pkg-2_src_prepare
+ egit_clean
+
+ # Enable CMake to install our .service file for systemd usage
+ mkdir -vp "${S}/src/cpp/server/lib/systemd/system" || die
+ cp -v "${FILESDIR}/rstudio-server.service.in" "${S}/src/cpp/server/lib/systemd/system/" || die
+
+ # Adding -DDISTRO_SHARE=... to append-flags breaks cmake so using
+ # this sed hack for now. ~RMH
+ sed -i \
+ -e "s|DISTRO_SHARE|\"share/${PN}\"|g" \
+ src/cpp/server/ServerOptions.cpp \
+ src/cpp/session/SessionOptions.cpp || die
+
+ # use mathjax from system
+ ln -sf "${EPREFIX}"/usr/share/mathjax dependencies/common/mathjax-26 || die
+
+ # make sure icons and mime stuff are with prefix
+ sed -i \
+ -e "s:/usr:${EPREFIX}/usr:g" \
+ CMakeGlobals.txt src/cpp/desktop/CMakeLists.txt || die
+
+ # install themes in /etc/rstudio/extra/sthemes instead of /usr/extra/themes
+ sed -i \
+ -e "s@\(DESTINATION \"\)\(extras/themes\"\)@\1${EROOT}/etc/rstudio/\2@" \
+ src/cpp/server/CMakeLists.txt || die
+
+ # On Gentoo the rstudio-server configuration file is /etc/conf.d/rstudio-server.conf
+ sed -e "s@/etc/rstudio/rserver.conf@${EROOT}/etc/conf.d/rstudio-server.conf@" \
+ -i src/cpp/server/ServerOptions.cpp \
+ || die
+
+ # Set the rsession.conf file location for Gentoo prefix
+ sed -e "s@/etc/rstudio/rsession.conf@${EROOT}/etc/rstudio/rsession.conf@" \
+ -i src/cpp/session/SessionOptions.cpp \
+ || die
+
+ # dev-qt/qtsingleapplication-2.6.1_p20150629 does not provide a cmake module.
+ # It provides a library that has its version number appended to the end,
+ # which is difficult to handle in cmake, as find_library does not support
+ # searching for wildcard library names. So I find the library name from the
+ # qmake spec, and then sed this into the patched src/cpp/desktop/CMakeLists.txt.
+ rm -rf "${S}"/src/cpp/desktop/3rdparty || die
+ local s=$(grep '\-lQt$${QT_MAJOR_VERSION}Solutions_SingleApplication' \
+ $(qt5_get_mkspecsdir)/features/qtsingleapplication.prf \
+ | sed -e 's@\$\${QT_MAJOR_VERSION}@5@' \
+ -e 's@LIBS \*= -l@@')
+ sed -e "s@Qt5Solutions_SingleApplication-2.6@${s}@g" \
+ -i "${S}"/src/cpp/desktop/CMakeLists.txt \
+ || die
+
+ # The git commit for tag: git rev-list -n 1 v${PV}
+ sed -e 's@git ARGS rev-parse HEAD@echo ARGS 5a4dee980c998d9a270a83b582b367126f3914cf@'\
+ -i "${S}"/CMakeLists.txt \
+ "${S}"/CMakeGlobals.txt \
+ || die
+
+ eprefixify src/gwt/build.xml
+}
+
+src_configure() {
+ export RSTUDIO_VERSION_MAJOR=$(ver_cut 1)
+ export RSTUDIO_VERSION_MINOR=$(ver_cut 2)
+ export RSTUDIO_VERSION_PATCH=$(ver_cut 3)
+
+ local mycmakeargs=(
+ -DDISTRO_SHARE=share/${PN}
+ -DRSTUDIO_TARGET=$(usex dedicated "Server" "$(usex server "Development" "Desktop")")
+ -DRSTUDIO_VERIFY_R_VERSION=FALSE
+ -DRSTUDIO_USE_SYSTEM_BOOST=TRUE
+ )
+
+ if use !dedicated; then
+ mycmakeargs+=(
+ -DRSTUDIO_INSTALL_FREEDESKTOP="$(usex !dedicated "ON" "OFF")"
+ -DQT_QMAKE_EXECUTABLE=$(qt5_get_bindir)/qmake
+ )
+ fi
+ cmake_src_configure
+}
+
+src_compile() {
+ local JAVA_ANT_REWRITE_CLASSPATH="yes"
+ local EANT_BUILD_XML="src/gwt/build.xml"
+ local EANT_BUILD_TARGET="clean"
+ java-pkg-2_src_compile
+
+ # Avoid the rest of the oracle-jdk-bin-1.8.0.60 sandbox violations F: mkdir S: deny
+ # P: /root/.oracle_jre_usage.
+ export ANT_OPTS="-Duser.home=${T}"
+ cmake_src_compile
+}
+
+src_install() {
+ export ANT_OPTS="-Duser.home=${T}"
+ cmake_src_install
+ use dedicated || pax-mark m "${ED}/usr/bin/rstudio"
+ doconfd "${FILESDIR}"/rstudio-server.conf
+ insinto /etc/rstudio
+ doins "${FILESDIR}"/rsession.conf
+ dosym ../conf.d/rstudio-server.conf /etc/rstudio/rserver.conf
+ if use dedicated || use server; then
+ dopamd src/cpp/server/extras/pam/rstudio
+ newinitd "${FILESDIR}"/rstudio-server.initd rstudio-server
+ fi
+}
+
+pkg_preinst() {
+ java-pkg-2_pkg_preinst
+}
+
+pkg_postinst() {
+ use dedicated || { xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ xdg_icon_cache_update ;}
+}
+
+pkg_postrm() {
+ use dedicated || { xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ xdg_icon_cache_update ;}
+}