summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-30 10:33:23 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-30 11:04:20 +0100
commit9aa122d1addcc1af1f8448607201e620ff309d50 (patch)
tree30b18c6ee0400eee3b357eb6b5c05d249a662b2b
parentdev-python/python-discid: Switch to PEP 517 build (diff)
downloadgentoo-9aa122d1.tar.gz
gentoo-9aa122d1.tar.bz2
gentoo-9aa122d1.zip
dev-python/python-gflags: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-gflags/python-gflags-3.1.2-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/python-gflags/python-gflags-3.1.2-r2.ebuild b/dev-python/python-gflags/python-gflags-3.1.2-r2.ebuild
new file mode 100644
index 000000000000..251a537291ce
--- /dev/null
+++ b/dev-python/python-gflags/python-gflags-3.1.2-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google's Python argument parsing library"
+HOMEPAGE="https://github.com/google/python-gflags"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.1.1-script-install.patch )
+
+python_test() {
+ # note: each test needs to be run separately, otherwise they fail
+ "${EPYTHON}" -m gflags._helpers_test -v || die
+ "${EPYTHON}" -m gflags.flags_formatting_test -v || die
+ "${EPYTHON}" -m gflags.flags_unicode_literals_test -v || die
+}