summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2023-06-20 12:31:12 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2023-06-20 14:16:20 -0700
commit9aab476a565acfa2270a22c92d1efa129c3f8693 (patch)
treed4739e65c80d725e57ff1b79b453f9f58bdbd6ec
parentwww-client/opera-developer: remove old (diff)
downloadgentoo-9aab476a.tar.gz
gentoo-9aab476a.tar.bz2
gentoo-9aab476a.zip
www-client/firefox: fix/keyword 114.0 on ppc64
Bug: https://bugs.gentoo.org/908297 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--www-client/firefox/files/firefox-114-ppc64-webrtc.patch35
-rw-r--r--www-client/firefox/firefox-114.0.ebuild7
2 files changed, 41 insertions, 1 deletions
diff --git a/www-client/firefox/files/firefox-114-ppc64-webrtc.patch b/www-client/firefox/files/firefox-114-ppc64-webrtc.patch
new file mode 100644
index 000000000000..14e8c4a6baaa
--- /dev/null
+++ b/www-client/firefox/files/firefox-114-ppc64-webrtc.patch
@@ -0,0 +1,35 @@
+#https://www.talospace.com/2023/06/firefox-114-on-power.html
+#https://gist.github.com/classilla/95b5dd53627528448f8512a82205672c
+
+diff -r 954df08c7f0b third_party/libwebrtc/moz.build
+--- a/third_party/libwebrtc/moz.build Tue Jun 06 08:55:21 2023 +0000
++++ b/third_party/libwebrtc/moz.build Mon Jun 19 09:33:12 2023 -0700
+@@ -595,16 +595,28 @@
+ "/third_party/libwebrtc/modules/desktop_capture/primitives_gn",
+ "/third_party/libwebrtc/modules/portal/portal_gn",
+ "/third_party/libwebrtc/third_party/drm/drm_gn",
+ "/third_party/libwebrtc/third_party/gbm/gbm_gn",
+ "/third_party/libwebrtc/third_party/libepoxy/libepoxy_gn",
+ "/third_party/libwebrtc/third_party/pipewire/pipewire_gn"
+ ]
+
++if CONFIG["CPU_ARCH"] == "ppc64" and CONFIG["OS_TARGET"] == "Linux":
++
++ DIRS += [
++ "/third_party/libwebrtc/modules/desktop_capture/desktop_capture_gn",
++ "/third_party/libwebrtc/modules/desktop_capture/primitives_gn",
++ "/third_party/libwebrtc/modules/portal/portal_gn",
++ "/third_party/libwebrtc/third_party/drm/drm_gn",
++ "/third_party/libwebrtc/third_party/gbm/gbm_gn",
++ "/third_party/libwebrtc/third_party/libepoxy/libepoxy_gn",
++ "/third_party/libwebrtc/third_party/pipewire/pipewire_gn"
++ ]
++
+ if CONFIG["CPU_ARCH"] == "aarch64" and CONFIG["OS_TARGET"] == "OpenBSD":
+
+ DIRS += [
+ "/third_party/libwebrtc/common_audio/common_audio_neon_c_gn",
+ "/third_party/libwebrtc/common_audio/common_audio_neon_gn"
+ ]
+
+ if CONFIG["CPU_ARCH"] == "x86_64" and CONFIG["OS_TARGET"] == "OpenBSD":
diff --git a/www-client/firefox/firefox-114.0.ebuild b/www-client/firefox/firefox-114.0.ebuild
index bdf003b7fd5c..2c6e7a02b3f9 100644
--- a/www-client/firefox/firefox-114.0.ebuild
+++ b/www-client/firefox/firefox-114.0.ebuild
@@ -647,7 +647,12 @@ src_unpack() {
src_prepare() {
use lto && rm -v "${WORKDIR}"/firefox-patches/*-LTO-Only-enable-LTO-*.patch
- ! use ppc64 && rm -v "${WORKDIR}"/firefox-patches/*bmo-1775202-ppc64*.patch
+ #! use ppc64 && rm -v "${WORKDIR}"/firefox-patches/*bmo-1775202-ppc64*.patch
+
+ # temp workaround for https://bugs.gentoo.org/908297 until patch added to tarball
+ rm -v "${WORKDIR}"/firefox-patches/*bmo-1775202-ppc64*.patch
+ use ppc64 && eapply "${FILESDIR}"/firefox-114-ppc64-webrtc.patch
+ # end temp workaround
eapply "${WORKDIR}/firefox-patches"