summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-03-02 10:04:08 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-03-02 10:04:17 +0100
commit9aba72a89b3d40e1ce521282a21db1c5dad0b7d0 (patch)
tree0d6cdbcecf298a4007738ddc97acd71765226f29
parentmedia-gfx/displaycal: 3.8.9.3 bump (diff)
downloadgentoo-9aba72a8.tar.gz
gentoo-9aba72a8.tar.bz2
gentoo-9aba72a8.zip
media-libs/liblo: Bump to version 0.31
Package-Manager: Portage-2.3.91, Repoman-2.3.20 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--media-libs/liblo/Manifest1
-rw-r--r--media-libs/liblo/liblo-0.31.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/media-libs/liblo/Manifest b/media-libs/liblo/Manifest
index bd9d2de3df3e..09c8edf0d728 100644
--- a/media-libs/liblo/Manifest
+++ b/media-libs/liblo/Manifest
@@ -1 +1,2 @@
DIST liblo-0.30.tar.gz 641498 BLAKE2B d884cc723d770f45414e838b6f2520c1f3b2a11972a9977d19b20ba68bc653f895eeb21ba0182a09fde1f096c9be084def1572f747463cd71e96bf0022ef7549 SHA512 51132933cc23237b70ed08fa7986a4a9f838529b83807746b358bcc171f8bbce7f37115b7c855520c9219bae93c74e502aebfb90e44dabdc6d0a00b8335336e3
+DIST liblo-0.31.tar.gz 643928 BLAKE2B 724a6369856b5f2ccd50edb8eacbf309760548b1f855d8b4f343cbfc3257ab3ceffc5f4e40d594ecb20050fcea11b7a6bc26f8e4a6ea72969628ebef05209fd5 SHA512 97f9561296c2e53f92db0cfee625687208b490f8bc229b6cffe88b43ca2a8da1ed3217aaa2151245ea483e54ad6c5e92b9cf10a20661766fa6d3bedb5a8cdd01
diff --git a/media-libs/liblo/liblo-0.31.ebuild b/media-libs/liblo/liblo-0.31.ebuild
new file mode 100644
index 000000000000..2a9f890560a6
--- /dev/null
+++ b/media-libs/liblo/liblo-0.31.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Lightweight OSC (Open Sound Control) implementation"
+HOMEPAGE="https://sourceforge.net/projects/liblo/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~ppc-macos"
+IUSE="doc ipv6 static-libs"
+
+RESTRICT="test"
+
+BDEPEND="doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ default
+
+ # don't build examples by default
+ sed -i '/^SUBDIRS =/s/examples//' Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ use doc || export ac_cv_prog_HAVE_DOXYGEN=false
+
+ # switching threads on/off breaks ABI, bugs #473282, #473286 and #473356
+ myeconfargs=(
+ --enable-threads
+ $(use_enable ipv6)
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name "*.la" -delete || die
+}