summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-25 03:23:46 +0100
committerSam James <sam@gentoo.org>2022-06-25 03:23:46 +0100
commit9accb2f9e19deab7e6d74d60e13a708bb33be6aa (patch)
tree9c0345166b7573b95a6dc3341d4597e256792dc8
parentdev-python/scipy: add 1.9.0_rc1 (diff)
downloadgentoo-9accb2f9e19deab7e6d74d60e13a708bb33be6aa.tar.gz
gentoo-9accb2f9e19deab7e6d74d60e13a708bb33be6aa.tar.bz2
gentoo-9accb2f9e19deab7e6d74d60e13a708bb33be6aa.zip
dev-embedded/platformio: unpin semantic_version
Bug: https://bugs.gentoo.org/853247 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-embedded/platformio/files/platformio-5.2.5-fix-semantic-version-dep.patch12
-rw-r--r--dev-embedded/platformio/platformio-5.2.5-r2.ebuild (renamed from dev-embedded/platformio/platformio-5.2.5-r1.ebuild)4
2 files changed, 16 insertions, 0 deletions
diff --git a/dev-embedded/platformio/files/platformio-5.2.5-fix-semantic-version-dep.patch b/dev-embedded/platformio/files/platformio-5.2.5-fix-semantic-version-dep.patch
new file mode 100644
index 000000000000..1fa92fed8784
--- /dev/null
+++ b/dev-embedded/platformio/files/platformio-5.2.5-fix-semantic-version-dep.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/853247
+--- a/setup.py
++++ b/setup.py
+@@ -35,7 +35,7 @@ minimal_requirements = [
+ "pyelftools>=0.27,<1",
+ "pyserial==3.*",
+ "requests==2.*",
+- "semantic_version==2.9.*",
++ "semantic_version==2.*",
+ "tabulate==0.8.*",
+ ]
+
diff --git a/dev-embedded/platformio/platformio-5.2.5-r1.ebuild b/dev-embedded/platformio/platformio-5.2.5-r2.ebuild
index 9c73bc3fd57d..9c0cbfa5bbd5 100644
--- a/dev-embedded/platformio/platformio-5.2.5-r1.ebuild
+++ b/dev-embedded/platformio/platformio-5.2.5-r2.ebuild
@@ -68,6 +68,10 @@ EPYTEST_IGNORE=(
distutils_enable_tests pytest
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.2.5-fix-semantic-version-dep.patch
+)
+
src_prepare() {
# Allow newer versions of zeroconf, Bug #831181.
# Also wsproto.