summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-14 04:58:28 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-14 05:12:31 +0100
commit9ace4f554910faa6fb27ae852a435323ee40d95e (patch)
tree1c927ab91591e73ba0d043d528c9f3a87734fc02
parentdev-python/sphinxcontrib-autoprogram: Bump to 0.1.9 (diff)
downloadgentoo-9ace4f55.tar.gz
gentoo-9ace4f55.tar.bz2
gentoo-9ace4f55.zip
dev-python/mkdocstrings-python: Bump to 1.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/mkdocstrings-python/Manifest1
-rw-r--r--dev-python/mkdocstrings-python/mkdocstrings-python-1.9.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/mkdocstrings-python/Manifest b/dev-python/mkdocstrings-python/Manifest
index 7b068ec4b768..27b729c76327 100644
--- a/dev-python/mkdocstrings-python/Manifest
+++ b/dev-python/mkdocstrings-python/Manifest
@@ -1 +1,2 @@
DIST mkdocstrings-python-1.8.0.gh.tar.gz 146162 BLAKE2B cd247b18de00dd4a53c287ec6d72461b0d0c2c95d49b20c24ce81d4304b92d48b8c8df78f35ad4749c928440ceddb4524ac64fcf3c99a50c18cbdaff9057f27a SHA512 5084df08a7d341b2e3ea93454706c38e2f29229122e6f2a277967c21c899d945cf4f6ae299782d8f6edffb48c1e23778ce445fb353727f2d5ceada74428ab3b9
+DIST mkdocstrings-python-1.9.0.gh.tar.gz 148843 BLAKE2B d84527c1eb03da4a1e154c8e592f91530cd3f90603063e1fcb0dc88cd0f9c5459a64d116c38154ffaaa557b6e298e28d51948c56979d87819de2665efa51bc30 SHA512 c6652f6027e3e416906b379b824bb59032439cb275a62a8bb0fd1f06324d485f582db5464358166f7b1545809bf929744cd3b96707e2c50132c2db5f3fa41785
diff --git a/dev-python/mkdocstrings-python/mkdocstrings-python-1.9.0.ebuild b/dev-python/mkdocstrings-python/mkdocstrings-python-1.9.0.ebuild
new file mode 100644
index 000000000000..604d9b56a237
--- /dev/null
+++ b/dev-python/mkdocstrings-python/mkdocstrings-python-1.9.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=pdm-backend
+
+inherit distutils-r1
+
+DESCRIPTION="Python handler for dev-python/mkdocstrings"
+HOMEPAGE="
+ https://mkdocstrings.github.io/python/
+ https://github.com/mkdocstrings/python/
+ https://pypi.org/project/mkdocstrings-python/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=dev-python/griffe-0.37[${PYTHON_USEDEP}]
+ <dev-python/markdown-3.6[${PYTHON_USEDEP}]
+ dev-python/mkdocstrings[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}