summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-11 15:21:18 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-11 15:23:12 +0200
commit9ad4558c6cc3900283d01f34935123027a2432ef (patch)
tree0a4c1b4c15c5169dc7c4e401c0500170d6e3d58e
parentdev-libs/libspt: update to EAPI 7 (diff)
downloadgentoo-9ad4558c6cc3900283d01f34935123027a2432ef.tar.gz
gentoo-9ad4558c6cc3900283d01f34935123027a2432ef.tar.bz2
gentoo-9ad4558c6cc3900283d01f34935123027a2432ef.zip
dev-ros/roscpp_tutorials: Bump to 0.10.2.
Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ros/roscpp_tutorials/Manifest1
-rw-r--r--dev-ros/roscpp_tutorials/roscpp_tutorials-0.10.2.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/roscpp_tutorials/Manifest b/dev-ros/roscpp_tutorials/Manifest
index 82eb97f90c3c..b03baf6abde3 100644
--- a/dev-ros/roscpp_tutorials/Manifest
+++ b/dev-ros/roscpp_tutorials/Manifest
@@ -1 +1,2 @@
DIST ros_tutorials-0.10.1.tar.gz 159522 BLAKE2B b0e045c6ee62cb68dfa977d17125af23d8ef80a619e822d245531a6cb3520a4d53120769e74ae2ba9af2813ce968e0c4fb22b7655eadd13b1a720705a9f75374 SHA512 592edb84f2e0ea80b2757ae890f495e8cb93d867b1bc6d64e6446f28fcffbd48c05703ac30ac29fd184a689f465728a5958d8c747587c756b53341c1d0740684
+DIST ros_tutorials-0.10.2.tar.gz 159630 BLAKE2B 6b7ea4c0aba110b746052a42150dd4e9faedbb1e4ab5a44bbef7c1079192238ac22bb18fc9968ea9e4450dde47bf1f5b7dabc0788aa8c232dfef3d1039a63f2e SHA512 73b420acf20a468f51db891fe0b0b33c3c838ea6fab4c03faab9a7abedc3ee68ec27ef0e70869143d0a22941eb77bac1fc80542cc0c14988ff75cb9685c174c5
diff --git a/dev-ros/roscpp_tutorials/roscpp_tutorials-0.10.2.ebuild b/dev-ros/roscpp_tutorials/roscpp_tutorials-0.10.2.ebuild
new file mode 100644
index 000000000000..73bab99e031e
--- /dev/null
+++ b/dev-ros/roscpp_tutorials/roscpp_tutorials-0.10.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/ros_tutorials"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Attempts to show the features of ROS step-by-step"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/rostime
+ dev-ros/roscpp
+ dev-ros/rosconsole
+ dev-ros/roscpp_serialization
+"
+DEPEND="${RDEPEND}"