summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-06 04:26:01 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-06 04:40:53 +0200
commit9ad5f9594888532b4d67ac5f1813e4bef8440628 (patch)
treef8193c6f23e6d03877616642c7418554587cbeb6
parentdev-python/ansible-compat: Bump to 4.1.9 (diff)
downloadgentoo-9ad5f9594888532b4d67ac5f1813e4bef8440628.tar.gz
gentoo-9ad5f9594888532b4d67ac5f1813e4bef8440628.tar.bz2
gentoo-9ad5f9594888532b4d67ac5f1813e4bef8440628.zip
dev-python/mkdocstrings-python: Bump to 1.6.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/mkdocstrings-python/Manifest1
-rw-r--r--dev-python/mkdocstrings-python/mkdocstrings-python-1.6.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/mkdocstrings-python/Manifest b/dev-python/mkdocstrings-python/Manifest
index 4e6fe17ea024..1455b14f6207 100644
--- a/dev-python/mkdocstrings-python/Manifest
+++ b/dev-python/mkdocstrings-python/Manifest
@@ -3,3 +3,4 @@ DIST mkdocstrings-python-1.5.1.gh.tar.gz 135102 BLAKE2B 06da82fd75b5f4311e983160
DIST mkdocstrings-python-1.5.2.gh.tar.gz 135238 BLAKE2B 09885164675a0955dcbef0a17871a6d19dbbfc9a7d6114a46e23dbb5a2428e7d46ffe626ecab10939934c06817892cde0e3e3db592776f7fb25dcdbdf8473a85 SHA512 0f069b07cb681ad470947dd02996e783ee809f34418316e8929322f20304dddab7049bc5dc0874e0b4ff6f6af6d958bbb69a4c61515d56cc716a774a1957f51e
DIST mkdocstrings-python-1.6.0.gh.tar.gz 135452 BLAKE2B cde95f8066ac97cbe3f618cb399cdcc06027632100198a7cd5970c09683a1d1bbe2b7aa32dcc8dae437b19efe4de007cd04899564a44021ad1e1794b7b9d5da7 SHA512 58da4eb6e3c7d702782346ca5b66726fe1f24c4a0f57a90bd5ab53ef90787eb16291d492078f10a847a6cbf63892b34a8d8d41714311664c659bf14acc0739a7
DIST mkdocstrings-python-1.6.1.gh.tar.gz 135536 BLAKE2B 34e0c43d73002988b6511b8027c910085f7f241895e28048c30944b303f9882af5335f52bf201c14055db7df31e051e9d2c1ec696777c9fc87e547d776684ba0 SHA512 429ca933fef33668c02081bdd539a556a7322f4759af6db74255ee39d4ad5f8a37f6626c58457eaaeabc76e559be8834bfe952e8bdb09f9924a86cb56faabbeb
+DIST mkdocstrings-python-1.6.2.gh.tar.gz 135683 BLAKE2B 2f8cbb10c5b8f69cb530f71d34fee73334ebc5dd52919ae53b67d5298ae8d416ea92cb0a38ee411b11ff65713d0d5dbd3cf877b338d82f24e24b6a7b62924694 SHA512 aac206ac0440eb64d53f82f22e3d924879c2a4df953c603139739a753b64c1c3cce05828948881ff2c7e0c1f49b94b0847797d22f92d86dc1ae449cc8aa7d677
diff --git a/dev-python/mkdocstrings-python/mkdocstrings-python-1.6.2.ebuild b/dev-python/mkdocstrings-python/mkdocstrings-python-1.6.2.ebuild
new file mode 100644
index 000000000000..f0b94cc2c39d
--- /dev/null
+++ b/dev-python/mkdocstrings-python/mkdocstrings-python-1.6.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=pdm-backend
+
+inherit distutils-r1
+
+DESCRIPTION="Python handler for dev-python/mkdocstrings"
+HOMEPAGE="
+ https://mkdocstrings.github.io/python/
+ https://github.com/mkdocstrings/python/
+ https://pypi.org/project/mkdocstrings-python/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=dev-python/griffe-0.35[${PYTHON_USEDEP}]
+ dev-python/mkdocstrings[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}