summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-30 11:36:24 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-30 12:32:45 +0300
commit9ae6ae5b4641c07b7d99cfcd7c2e08a8afa88b3a (patch)
treea3db82208f2c0017321e628a12999952b1eedab4
parentdev-python/pep517: add 0.13.0 (diff)
downloadgentoo-9ae6ae5b.tar.gz
gentoo-9ae6ae5b.tar.bz2
gentoo-9ae6ae5b.zip
dev-python/cfn-lint: add 0.61.4
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.61.4.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 2d5c1b3d89a5..d6e5a1a9c5a5 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1,3 +1,4 @@
DIST cfn-lint-0.61.1.gh.tar.gz 9351410 BLAKE2B 442fa5957f8816dc501e91593873c28b1b2e39ec14870b82574d4ca351f321b94a813fd351cc09c7602a177a8451d09cf8459c8aa47b683b9938654c99476e19 SHA512 63071cd1df0115624341fb64bd12a51d7bd38fe4993229a790ca09011b370487cb49397d90916f4df42b5c978cd3832e2de4cec15660ac8668e994adc0e681c3
DIST cfn-lint-0.61.2.gh.tar.gz 9477584 BLAKE2B 8b65151edcd9323dd44d6a77c39fb3dd90a1934bc1cf3e6cb419e6a33595afeb740591a77a80178cbaa5dadd5183759064807a5a135545c2fb7e8c5a2c8970ba SHA512 ed8e9813f1d12ec0ded203c4c2246592c2aa3466f69ee2a478d9ac579807a610836d862768c259ebec6e421bbe92a5a120c056a5e4b70873e6e044e0c606d021
DIST cfn-lint-0.61.3.gh.tar.gz 9528542 BLAKE2B 27f5c82c09a7c1dde520189647480032faf808089083ca45a9a2a24e4c158cb8e62ee6ae2f906d6c68021cc34b654ff46c9402876e09dd3330115dead5db44a8 SHA512 db5369a12d88754f6241b4ef529b53d142a80bfcb0c58ac7ec03217e7e4cb7e53f3fde1dde45dfdac82ab3fde4b885bb40dae3076b85edf34ca68cc73dc5aeb1
+DIST cfn-lint-0.61.4.gh.tar.gz 9556069 BLAKE2B 71572546d7e523c11214e32130a7d52461580e487b514846137e6592cb7a1786414556e4bea191aa2e4dddaf338c24e8ea9001e617221ea74b03bd0ea900a5a9 SHA512 fd85af770b5b519c9de4df0acbbaa66a8a7f61efd210a793c2e28ad9e6d6ed2d8b3042ca41d7743b2bc4dc0446b42ea2929cba454fdbf097a482a7c268e04000
diff --git a/dev-python/cfn-lint/cfn-lint-0.61.4.ebuild b/dev-python/cfn-lint/cfn-lint-0.61.4.ebuild
new file mode 100644
index 000000000000..57fd1d8c6029
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.61.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="
+ https://github.com/aws-cloudformation/cfn-lint/
+ https://pypi.org/project/cfn-lint/
+"
+SRC_URI="
+ https://github.com/aws-cloudformation/cfn-lint/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.47.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_2
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+)
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}