summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2021-01-05 23:28:30 +0100
committerUlrich Müller <ulm@gentoo.org>2021-01-06 17:56:57 +0100
commit9ae8af354671c47567207457d0ebf3ed01b8afb3 (patch)
tree171aad4753644d3fd6d0a4ec4c3235d9c1a2b05b
parentdev-tcltk/vtcl: bump to 1.6.1a1 (diff)
downloadgentoo-9ae8af35.tar.gz
gentoo-9ae8af35.tar.bz2
gentoo-9ae8af35.zip
app-editors/mg: Version bump to 20200723
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--app-editors/mg/Manifest1
-rw-r--r--app-editors/mg/mg-20200723.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-editors/mg/Manifest b/app-editors/mg/Manifest
index 2b9dde66083e..1466de3577f2 100644
--- a/app-editors/mg/Manifest
+++ b/app-editors/mg/Manifest
@@ -1 +1,2 @@
DIST mg-20200215.tar.gz 152254 BLAKE2B 89e47aaa94fd95b9409a53b09c9017e26d3f1cc73ce616e1c29ed22fbaed42cb78e7c9fbcd2424d98f86725fb00cee5160be4fe40abc97a927201557b684f800 SHA512 c6cda5544210bc3d3fa3cbb8494e60949e10ed3716d96b76d0c9e7f5671c7a85f6e7e7a860cfd05466f1bf52112053c722441ff338210c0ada89f10515ac170a
+DIST mg-20200723.tar.gz 152271 BLAKE2B 5fcbe2699da60c68a0c464bb337741d7797e9da3e2ab148a821aed46f661e5f5efbe7ceb14b153dcdd51185d22d0a2b2c7ad3525fc531192ecc0c0697e483b77 SHA512 8e481cf4981b93dba95b3b318f44dda15e580962216d452ce2fddcd19b86e4686673ba84d092bfaa540533b227428bd3bc9e6becda69be881d930937b0ea7add
diff --git a/app-editors/mg/mg-20200723.ebuild b/app-editors/mg/mg-20200723.ebuild
new file mode 100644
index 000000000000..20816904f732
--- /dev/null
+++ b/app-editors/mg/mg-20200723.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="MicroGnuEmacs, a port from the BSDs"
+HOMEPAGE="https://homepage.boetes.org/software/mg/"
+SRC_URI="https://github.com/hboetes/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="livecd"
+
+RDEPEND="sys-libs/ncurses:0
+ !elibc_FreeBSD? ( >=dev-libs/libbsd-0.7.0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # fix path to tutorial in man page
+ sed -i -e "s:doc/mg/:doc/${PF}/:" mg.1 || die
+ eapply_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ dobin mg
+ doman mg.1
+ dodoc README tutorial
+ # don't compress the tutorial, otherwise mg cannot open it
+ docompress -x /usr/share/doc/${PF}/tutorial
+}
+
+pkg_postinst() {
+ if use livecd; then
+ [[ -e ${EROOT}/usr/bin/emacs ]] || ln -s mg "${EROOT}"/usr/bin/emacs
+ fi
+}