summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-17 07:24:31 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-17 08:25:33 +0200
commit9af76114ceb4bd0a12ed7f783045fec3971c451a (patch)
tree9fc377ece044e0dccb80c9c637b101b07a134f55
parentdev-python/Nuitka: Remove old (diff)
downloadgentoo-9af76114ceb4bd0a12ed7f783045fec3971c451a.tar.gz
gentoo-9af76114ceb4bd0a12ed7f783045fec3971c451a.tar.bz2
gentoo-9af76114ceb4bd0a12ed7f783045fec3971c451a.zip
dev-python/Nuitka: Bump to 2.2.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/Nuitka/Manifest1
-rw-r--r--dev-python/Nuitka/Nuitka-2.2.3.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/Nuitka/Manifest b/dev-python/Nuitka/Manifest
index 6c6e6b433001..8ee35085bd8d 100644
--- a/dev-python/Nuitka/Manifest
+++ b/dev-python/Nuitka/Manifest
@@ -1 +1,2 @@
DIST Nuitka-2.2.2.tar.gz 3999091 BLAKE2B 1512b0112dfa36c704900b787ac43a24377ab2994d16865d85da0384d2bb29a6dd26a83be270c51c28bcca68dad2398d68096d4dae1ee3f2044a85dad2571d82 SHA512 13f03fb849d83a1fbb10df2fe54f429f8871068942dfe93316460e1abed9149793b6fc1d7b62b1e72fc00de94ae9fd4b218f4ee65ea7668d138700f2bfd94eb2
+DIST Nuitka-2.2.3.tar.gz 3657438 BLAKE2B f01a213f7dff39b6bba50ba21fbd120927caa60c88156aa0e9094339f260008fe18aaec4aabe5f878224516bddde697020ac16795e528b0e0141937565255b0a SHA512 36147901a75fcefad10ec75b66a3c988be9c8d6f54aca0f2f9ab3a8c4b06efc7c1b4eb5af5686675ce7040948f7032c27a93f7ea2429e02b99c2d817c37c72fe
diff --git a/dev-python/Nuitka/Nuitka-2.2.3.ebuild b/dev-python/Nuitka/Nuitka-2.2.3.ebuild
new file mode 100644
index 000000000000..123acd66de1f
--- /dev/null
+++ b/dev-python/Nuitka/Nuitka-2.2.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 flag-o-matic optfeature pypi
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-build/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka.1 doc/nuitka-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" dev-util/patchelf
+}