summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2016-05-01 13:45:24 -0500
committerMatthias Maier <tamiko@gentoo.org>2016-05-01 14:15:04 -0500
commit9b146d56acd46538427c709608c17dfe34b43d05 (patch)
tree8581303ba6291f428166da49bfca6ea3ea5eff14
parentapp-emulation/libvirt: version bump to 1.3.4, bug #580418, bug #579960 (diff)
downloadgentoo-9b146d56.tar.gz
gentoo-9b146d56.tar.bz2
gentoo-9b146d56.zip
dev-python/libvirt-python: version bump to 1.3.4, bug #580418
Package-Manager: portage-2.2.26
-rw-r--r--dev-python/libvirt-python/Manifest1
-rw-r--r--dev-python/libvirt-python/libvirt-python-1.3.4.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/libvirt-python/Manifest b/dev-python/libvirt-python/Manifest
index 10ff3eae4c86..a12265121e13 100644
--- a/dev-python/libvirt-python/Manifest
+++ b/dev-python/libvirt-python/Manifest
@@ -2,3 +2,4 @@ DIST libvirt-python-1.2.21.tar.gz 171250 SHA256 7ffb49fcb64ac06188fc626c853c9936
DIST libvirt-python-1.3.0.tar.gz 171195 SHA256 097d41bc52c300e50c5b04836e078bae5653fe222db92a9a10839f3e6b3afc7c SHA512 b207aa9aef63e7d1a8377b2f8a0fa8dc05893bd744672c2b41f4dafa2516cbddd2868f37b0caf72b125fccbbf56542fcf1b94b452c406757f30d8f02d6ee26b4 WHIRLPOOL 1bde1fd130e0760bfa8f62c2f85e4ded991fc0eadcaf10b38bbbcf754eaa7b3a0ccb72f304f65457115419e4d3d904d07172e33bd68d581a29e4fb8d0703b45a
DIST libvirt-python-1.3.1.tar.gz 171221 SHA256 7143b922a9bd66a5e199b13316fa4266cbffc23db01c99bce37216a1eb9118f7 SHA512 f980d6aec1c83422d01c8ff02915357f4903f8c2a8ea9538da35e7313f6d491ebb4646e642097269a6be2996da879e7594c5e166cf2cc0bd96745eace7ce7567 WHIRLPOOL 3fe0ecba5f618eab1059c5e4ac4ef8789ed6684f36aee336f2e366198805560706c41d67ddceb328a0ad66867145a103aa15665b646b7bc5a5b058b02755ce11
DIST libvirt-python-1.3.2.tar.gz 171673 SHA256 6d35ae9e7801573393b9c92471f39e6700d479f10b641df81d041b469f160bf8 SHA512 cd5a6f7e1a98fc87df137aa015b139dd78974a838fef7b3703ce1d0feb41babd6f1c20ef116675646a4be1052901431298382dbb7c6d0b11497cfe801296334e WHIRLPOOL 2fd73458aa19ac0067c264f0b9f42a7ae1313d72a77977b690691b3867dd717f28e67d2862556ada0d0c0fbfb70444eb5a5d28fd38b19402c0fbbcc713af157a
+DIST libvirt-python-1.3.4.tar.gz 172808 SHA256 badd2f51b07d5b03be7c01c45d8f52fea181ba9386ced5b12241ffdcf7e4f7a7 SHA512 18063021edf28b6c7b6b407590ec94eda45272c6b976ef560b4e81a8b212a5c7d2c1ce844e066855cda0a1bca4e98028936314c58e12261952783bd606501f59 WHIRLPOOL 73e2a9a1327efad4e448bb08814ddbe5c8958bcdbe596ea539be39e3a34ff9ffed141aac40bd90d4c0b841e1ddd42f6d7905245499efa774dca6f99c16305814
diff --git a/dev-python/libvirt-python/libvirt-python-1.3.4.ebuild b/dev-python/libvirt-python/libvirt-python-1.3.4.ebuild
new file mode 100644
index 000000000000..cc59d1ba63b0
--- /dev/null
+++ b/dev-python/libvirt-python/libvirt-python-1.3.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+AUTOTOOLIZE=yes
+
+MY_P="${P/_rc/-rc}"
+
+inherit eutils distutils-r1
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://libvirt.org/libvirt-python.git"
+ SRC_URI=""
+ KEYWORDS=""
+ RDEPEND="app-emulation/libvirt:=[-python(-)]"
+else
+ SRC_URI="http://libvirt.org/sources/python/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ RDEPEND="app-emulation/libvirt:0/${PV}"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="http://www.libvirt.org"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="test"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+# testsuite is currently not included in upstream tarball
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}