summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-10-25 11:29:54 -0400
committerMatt Turner <mattst88@gentoo.org>2023-10-25 11:41:30 -0400
commit9b4db39b0d72f93d5c46898cb262d8c5349542cc (patch)
tree39f8fd497bc9b3933105c3edde7d5658fededb77
parentx11-base/xwayland: Version bump to 23.2.2 (diff)
downloadgentoo-9b4db39b0d72f93d5c46898cb262d8c5349542cc.tar.gz
gentoo-9b4db39b0d72f93d5c46898cb262d8c5349542cc.tar.bz2
gentoo-9b4db39b0d72f93d5c46898cb262d8c5349542cc.zip
x11-base/xorg-server: Version bump to 21.1.9
Bug: https://bugs.gentoo.org/916254 Closes: https://bugs.gentoo.org/884221 Closes: https://bugs.gentoo.org/909092 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-base/xorg-server/Manifest1
-rw-r--r--x11-base/xorg-server/files/xorg-server-21.1.9-xephyr-Don-t-check-for-SeatId-anymore.patch66
-rw-r--r--x11-base/xorg-server/xorg-server-21.1.9.ebuild194
3 files changed, 261 insertions, 0 deletions
diff --git a/x11-base/xorg-server/Manifest b/x11-base/xorg-server/Manifest
index 4aa30fb75c5f..26f511e9d9ed 100644
--- a/x11-base/xorg-server/Manifest
+++ b/x11-base/xorg-server/Manifest
@@ -1 +1,2 @@
DIST xorg-server-21.1.8.tar.xz 4980208 BLAKE2B a223efe6d14b55bd133b7f8db75b7720ea0ae58f1eced0f6b20caf6e7045e7649a0923a1c6db5d649265375e6768fa9811477d2fa0da52d7a1e65cf4511535d2 SHA512 6104b3620ed2e1e27d9a8e963388bbe8785a764585b1bc03dbf5d719a92894773dda580d377ca18ceeab353e65a5d23cc947bab84a4012f9dd1eca31cac36937
+DIST xorg-server-21.1.9.tar.xz 4935860 BLAKE2B 8e0a2e0f5fc4d06a08c1424fe618da9822e951f5b744b4cac1b1e14305ab598b162e4f08fb53ba5e60d0001257216755a576b470c961c26a909d66e9a46d1c77 SHA512 9044e1b9222616fb63aea444b75f4ca6582edb7d899018f8ea30359e57edf04b1555e69397ebc4d288f7e36d6b82a54dde3895f11d414573d229e908ac17bfe8
diff --git a/x11-base/xorg-server/files/xorg-server-21.1.9-xephyr-Don-t-check-for-SeatId-anymore.patch b/x11-base/xorg-server/files/xorg-server-21.1.9-xephyr-Don-t-check-for-SeatId-anymore.patch
new file mode 100644
index 000000000000..64581c9d0a18
--- /dev/null
+++ b/x11-base/xorg-server/files/xorg-server-21.1.9-xephyr-Don-t-check-for-SeatId-anymore.patch
@@ -0,0 +1,66 @@
+https://bugs.gentoo.org/884221
+https://gitlab.freedesktop.org/xorg/xserver/-/merge_requests/1192
+
+From 4c03b67d334b05b814239420776f2fdd4c4a98ac Mon Sep 17 00:00:00 2001
+From: nerdopolis <bluescreen_avenger@verizon.net>
+Date: Tue, 11 Jan 2022 18:41:42 -0500
+Subject: [PATCH xserver] xephyr: Don't check for SeatId anymore
+
+After a change for the xserver to automatically determine the seat
+based on the XDG_SEAT variable, xephyr stopped working. This was
+because of an old feature where xephyr used to handle evdev
+directly. This was dropped some time ago, and now this check is
+not needed
+---
+ hw/kdrive/ephyr/ephyrinit.c | 34 ++++++++++++++++------------------
+ 1 file changed, 16 insertions(+), 18 deletions(-)
+
+diff --git a/hw/kdrive/ephyr/ephyrinit.c b/hw/kdrive/ephyr/ephyrinit.c
+index 020461db2..09cd28cb3 100644
+--- a/hw/kdrive/ephyr/ephyrinit.c
++++ b/hw/kdrive/ephyr/ephyrinit.c
+@@ -70,25 +70,23 @@ InitInput(int argc, char **argv)
+ KdKeyboardInfo *ki;
+ KdPointerInfo *pi;
+
+- if (!SeatId) {
+- KdAddKeyboardDriver(&EphyrKeyboardDriver);
+- KdAddPointerDriver(&EphyrMouseDriver);
+-
+- if (!kdHasKbd) {
+- ki = KdNewKeyboard();
+- if (!ki)
+- FatalError("Couldn't create Xephyr keyboard\n");
+- ki->driver = &EphyrKeyboardDriver;
+- KdAddKeyboard(ki);
+- }
++ KdAddKeyboardDriver(&EphyrKeyboardDriver);
++ KdAddPointerDriver(&EphyrMouseDriver);
++
++ if (!kdHasKbd) {
++ ki = KdNewKeyboard();
++ if (!ki)
++ FatalError("Couldn't create Xephyr keyboard\n");
++ ki->driver = &EphyrKeyboardDriver;
++ KdAddKeyboard(ki);
++ }
+
+- if (!kdHasPointer) {
+- pi = KdNewPointer();
+- if (!pi)
+- FatalError("Couldn't create Xephyr pointer\n");
+- pi->driver = &EphyrMouseDriver;
+- KdAddPointer(pi);
+- }
++ if (!kdHasPointer) {
++ pi = KdNewPointer();
++ if (!pi)
++ FatalError("Couldn't create Xephyr pointer\n");
++ pi->driver = &EphyrMouseDriver;
++ KdAddPointer(pi);
+ }
+
+ KdInitInput();
+--
+2.41.0
+
diff --git a/x11-base/xorg-server/xorg-server-21.1.9.ebuild b/x11-base/xorg-server/xorg-server-21.1.9.ebuild
new file mode 100644
index 000000000000..f4b46fb4d12e
--- /dev/null
+++ b/x11-base/xorg-server/xorg-server-21.1.9.ebuild
@@ -0,0 +1,194 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX="xz"
+XORG_EAUTORECONF="no"
+inherit flag-o-matic xorg-3 meson
+EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/xserver.git"
+
+DESCRIPTION="X.Org X servers"
+SLOT="0/${PV}"
+if [[ ${PV} != 9999* ]]; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+IUSE_SERVERS="xephyr xnest xorg xvfb"
+IUSE="${IUSE_SERVERS} debug +elogind minimal selinux suid systemd test +udev unwind xcsecurity"
+RESTRICT="!test? ( test )"
+
+CDEPEND="
+ media-libs/libglvnd[X]
+ dev-libs/libbsd
+ dev-libs/openssl:0=
+ >=x11-apps/iceauth-1.0.2
+ >=x11-apps/xauth-1.0.3
+ x11-apps/xkbcomp
+ >=x11-libs/libdrm-2.4.89
+ >=x11-libs/libpciaccess-0.12.901
+ >=x11-libs/libXau-1.0.4
+ >=x11-libs/libXdmcp-1.0.2
+ >=x11-libs/libXfont2-2.0.1
+ >=x11-libs/libxkbfile-1.0.4
+ >=x11-libs/libxshmfence-1.1
+ >=x11-libs/pixman-0.27.2
+ >=x11-misc/xbitmaps-1.0.1
+ >=x11-misc/xkeyboard-config-2.4.1-r3
+ xorg? (
+ >=x11-libs/libxcvt-0.1.0
+ )
+ xnest? (
+ >=x11-libs/libXext-1.0.99.4
+ >=x11-libs/libX11-1.1.5
+ )
+ xephyr? (
+ x11-libs/libxcb
+ x11-libs/xcb-util
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util-renderutil
+ x11-libs/xcb-util-wm
+ )
+ !minimal? (
+ >=media-libs/mesa-18[X(+),egl(+),gbm(+)]
+ >=media-libs/libepoxy-1.5.4[X,egl(+)]
+ )
+ udev? ( virtual/libudev:= )
+ unwind? ( sys-libs/libunwind:= )
+ selinux? (
+ sys-process/audit
+ sys-libs/libselinux:=
+ )
+ systemd? (
+ sys-apps/dbus
+ sys-apps/systemd
+ )
+ elogind? (
+ sys-apps/dbus
+ sys-auth/elogind[pam]
+ sys-auth/pambase[elogind]
+ )
+ !!x11-drivers/nvidia-drivers[-libglvnd(+)]
+"
+DEPEND="${CDEPEND}
+ >=x11-base/xorg-proto-2021.4.99.2
+ >=x11-libs/xtrans-1.3.5
+ media-fonts/font-util
+ test? ( >=x11-libs/libxcvt-0.1.0 )
+"
+RDEPEND="${CDEPEND}
+ !systemd? ( gui-libs/display-manager-init )
+ selinux? ( sec-policy/selinux-xserver )
+ xorg? ( >=x11-apps/xinit-1.3.3-r1 )
+"
+BDEPEND="
+ sys-devel/flex
+"
+PDEPEND="
+ xorg? ( >=x11-base/xorg-drivers-$(ver_cut 1-2) )"
+
+REQUIRED_USE="!minimal? (
+ || ( ${IUSE_SERVERS} )
+ )
+ elogind? ( udev )
+ ?? ( elogind systemd )"
+
+UPSTREAMED_PATCHES=(
+)
+
+PATCHES=(
+ "${UPSTREAMED_PATCHES[@]}"
+ "${FILESDIR}"/${PN}-1.12-unloadsubmodule.patch
+ # needed for new eselect-opengl, bug #541232
+ "${FILESDIR}"/${PN}-1.18-support-multiple-Files-sections.patch
+
+ "${FILESDIR}"/${P}-xephyr-Don-t-check-for-SeatId-anymore.patch
+)
+
+src_configure() {
+ # bug #835653
+ use x86 && replace-flags -Os -O2
+
+ # localstatedir is used for the log location; we need to override the default
+ # from ebuild.sh
+ # sysconfdir is used for the xorg.conf location; same applies
+ local emesonargs=(
+ --localstatedir "${EPREFIX}/var"
+ --sysconfdir "${EPREFIX}/etc/X11"
+ --buildtype $(usex debug debug plain)
+ -Db_ndebug=$(usex debug false true)
+ $(meson_use !minimal dri1)
+ $(meson_use !minimal dri2)
+ $(meson_use !minimal dri3)
+ $(meson_use !minimal glamor)
+ $(meson_use !minimal glx)
+ $(meson_use udev)
+ $(meson_use udev udev_kms)
+ $(meson_use unwind libunwind)
+ $(meson_use xcsecurity)
+ $(meson_use selinux xselinux)
+ $(meson_use xephyr)
+ $(meson_use xnest)
+ $(meson_use xorg)
+ $(meson_use xvfb)
+ -Ddocs=false
+ -Ddrm=true
+ -Ddtrace=false
+ -Dipv6=true
+ -Dhal=false
+ -Dlinux_acpi=false
+ -Dlinux_apm=false
+ -Dsecure-rpc=false
+ -Dsha1=libcrypto
+ -Dxkb_output_dir="${EPREFIX}/var/lib/xkb"
+ )
+
+ if [[ ${PV} == 9999 ]] ; then
+ # Gone in 21.1.x, but not in master.
+ emesonargs+=( -Dxwayland=false )
+ fi
+
+ if use systemd || use elogind; then
+ emesonargs+=(
+ -Dsystemd_logind=true
+ $(meson_use suid suid_wrapper)
+ )
+ else
+ emesonargs+=(
+ -Dsystemd_logind=false
+ -Dsuid_wrapper=false
+ )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # The meson build system does not support install-setuid
+ if ! use systemd && ! use elogind; then
+ if use suid; then
+ chmod u+s "${ED}"/usr/bin/Xorg
+ fi
+ fi
+
+ if ! use xorg; then
+ rm -f "${ED}"/usr/share/man/man1/Xserver.1x \
+ "${ED}"/usr/$(get_libdir)/xserver/SecurityPolicy \
+ "${ED}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
+ "${ED}"/usr/share/man/man1/Xserver.1x || die
+ fi
+
+ # install the @x11-module-rebuild set for Portage
+ insinto /usr/share/portage/config/sets
+ newins "${FILESDIR}"/xorg-sets.conf xorg.conf
+}
+
+pkg_postrm() {
+ # Get rid of module dir to ensure opengl-update works properly
+ if [[ -z ${REPLACED_BY_VERSION} && -e ${EROOT}/usr/$(get_libdir)/xorg/modules ]]; then
+ rm -rf "${EROOT}"/usr/$(get_libdir)/xorg/modules
+ fi
+}