summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-09-08 13:50:05 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-09-08 13:55:17 +0300
commit9b83bcf936bc5b844cf785979dc631940d147a7d (patch)
tree57a5ce63e4d8e5e10ed1fa4aadc5617b045562aa
parentsci-geosciences/gnome-maps: remove old (diff)
downloadgentoo-9b83bcf9.tar.gz
gentoo-9b83bcf9.tar.bz2
gentoo-9b83bcf9.zip
sys-cluster/rdma-core: initial commit
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
-rw-r--r--sys-cluster/rdma-core/Manifest1
-rw-r--r--sys-cluster/rdma-core/files/ibacm.init7
-rw-r--r--sys-cluster/rdma-core/files/iwpmd.init7
-rw-r--r--sys-cluster/rdma-core/files/srpd.init20
-rw-r--r--sys-cluster/rdma-core/metadata.xml16
-rw-r--r--sys-cluster/rdma-core/rdma-core-24.0.ebuild92
-rw-r--r--sys-cluster/rdma-core/rdma-core-9999.ebuild91
7 files changed, 234 insertions, 0 deletions
diff --git a/sys-cluster/rdma-core/Manifest b/sys-cluster/rdma-core/Manifest
new file mode 100644
index 000000000000..195599ddb951
--- /dev/null
+++ b/sys-cluster/rdma-core/Manifest
@@ -0,0 +1 @@
+DIST rdma-core-24.0.tar.gz 1219485 BLAKE2B 400076305ca634a14d8f46df3477f9e3e753b95840237a217cfffe1a78e93ee90994e628f2a0693bde588ce15965df0014acb55bc92c36e3c45011cc69e9898a SHA512 0ef2b2b4250a1738adec964911a286f60e2310472c943dac1be45c70974a8bd1f32ee96013bff9e492132403af810aee1350d404a87ae7671731f7a5bd80c655
diff --git a/sys-cluster/rdma-core/files/ibacm.init b/sys-cluster/rdma-core/files/ibacm.init
new file mode 100644
index 000000000000..719accfa95c8
--- /dev/null
+++ b/sys-cluster/rdma-core/files/ibacm.init
@@ -0,0 +1,7 @@
+#!/sbin/openrc-run
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+command="/usr/sbin/ibacm"
+pidfile="/run/${SVCNAME}.pid"
+start_stop_daemon_args="-b -m"
diff --git a/sys-cluster/rdma-core/files/iwpmd.init b/sys-cluster/rdma-core/files/iwpmd.init
new file mode 100644
index 000000000000..b1ffa33fcc8a
--- /dev/null
+++ b/sys-cluster/rdma-core/files/iwpmd.init
@@ -0,0 +1,7 @@
+#!/sbin/openrc-run
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+command="/usr/sbin/iwpmd"
+pidfile="/run/${SVCNAME}.pid"
+start_stop_daemon_args="-b -m"
diff --git a/sys-cluster/rdma-core/files/srpd.init b/sys-cluster/rdma-core/files/srpd.init
new file mode 100644
index 000000000000..c54e5d81ed58
--- /dev/null
+++ b/sys-cluster/rdma-core/files/srpd.init
@@ -0,0 +1,20 @@
+#!/sbin/openrc-run
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+command="/usr/sbin/srp_daemon.sh"
+pidfile="/run/${SVCNAME}.pid"
+start_stop_daemon_args="-b -m"
+
+rdma_config="/etc/infiniband/openib.conf"
+[ -f ${rdma_config} ] && source ${rdma_config}"
+
+[ ${SRP_DEFAULT_TL_RETRY_COUNT} ] && command_args="-l ${SRP_DEFAULT_TL_RETRY_COUNT}"
+
+start_pre() {
+ if ! [ -e /sys/module/ib_srp ]; then
+ eerror "SRP kernel module is not loaded, unable to start SRP daemon"
+ return 1
+ fi
+ return 0
+}
diff --git a/sys-cluster/rdma-core/metadata.xml b/sys-cluster/rdma-core/metadata.xml
new file mode 100644
index 000000000000..25b5861a7599
--- /dev/null
+++ b/sys-cluster/rdma-core/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zlogene@gentoo.org</email>
+ <name>Mikle Kolyada</name>
+ </maintainer>
+ <use>
+ <flag name="neigh">Enable iwpmd support</flag>
+ <flag name="python">Enable pyverbs support</flag>
+ <flag name="valgrind">Enable valgrind notations</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">linux-rdma/rdma-core</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-cluster/rdma-core/rdma-core-24.0.ebuild b/sys-cluster/rdma-core/rdma-core-24.0.ebuild
new file mode 100644
index 000000000000..fb16737ff026
--- /dev/null
+++ b/sys-cluster/rdma-core/rdma-core-24.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit cmake-utils python-single-r1 udev systemd
+
+DESCRIPTION="Userspace components for the Linux Kernel's drivers/infiniband subsystem"
+HOMEPAGE="https://github.com/linux-rdma/rdma-core"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/linux-rdma/rdma-core"
+else
+ SRC_URI="https://github.com/linux-rdma/rdma-core/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="|| ( GPL-2 ( CC0-1.0 MIT BSD BSD-with-attribution ) )"
+SLOT="0"
+IUSE="neigh python static-libs systemd valgrind"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+COMMON_DEPEND="
+ virtual/libudev:=
+ neigh? ( dev-libs/libnl:3 )
+ systemd? ( sys-apps/systemd:= )
+ valgrind? ( dev-util/valgrind )
+ python? ( ${PYTHON_DEPS} )"
+
+DEPEND="${COMMON_DEPEND}
+ python? ( dev-python/cython[${PYTHON_USEDEP}] )"
+
+RDEPEND="${COMMON_DEPEND}
+ !sys-fabric/infiniband-diags
+ !sys-fabric/libibverbs
+ !sys-fabric/librdmacm
+ !sys-fabric/libibumad
+ !sys-fabric/ibacm
+ !sys-fabric/libibmad
+ !sys-fabric/srptools
+ !sys-fabric/infinipath-psm
+ !sys-fabric/libcxgb3
+ !sys-fabric/libcxgb4
+ !sys-fabric/libmthca
+ !sys-fabric/libmlx4
+ !sys-fabric/libmlx5
+ !sys-fabric/libocrdma
+ !sys-fabric/libnes"
+
+BDEPEND="virtual/pkgconfig"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc
+ -DCMAKE_INSTALL_FULL_RUNDIR=/run
+ -DCMAKE_INSTALL_UDEV_RULESDIR="$(get_udevdir)"/rules.d
+ -DCMAKE_INSTALL_SYSTEMD_SERVICEDIR="$(systemd_get_systemunitdir)"
+ -DCMAKE_DISABLE_FIND_PACKAGE_pandoc=yes
+ $(ver_test -ge 25 && echo -DCMAKE_DISABLE_FIND_PACKAGE_rst2man=yes)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Systemd="$(usex systemd no yes)"
+ -DENABLE_VALGRIND="$(usex valgrind)"
+ -DENABLE_RESOLVE_NEIGH="$(usex neigh)"
+ -DENABLE_STATIC="$(usex static-libs)"
+ )
+
+ if use python; then
+ mycmakeargs+=( -DNO_PYVERBS=OFF )
+ else
+ mycmakeargs+=( -DNO_PYVERBS=ON )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ udev_dorules "${D}"/etc/udev/rules.d/70-persistent-ipoib.rules
+ rm -r "${D}"/etc/{udev,init.d} || die
+
+ newinitd "${FILESDIR}"/ibacm.init ibacm
+ newinitd "${FILESDIR}"/iwpmd.init iwpmd
+ newinitd "${FILESDIR}"/srpd.init srpd
+}
diff --git a/sys-cluster/rdma-core/rdma-core-9999.ebuild b/sys-cluster/rdma-core/rdma-core-9999.ebuild
new file mode 100644
index 000000000000..bce36dc9cb68
--- /dev/null
+++ b/sys-cluster/rdma-core/rdma-core-9999.ebuild
@@ -0,0 +1,91 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit cmake-utils python-single-r1 udev systemd
+
+DESCRIPTION="Userspace components for the Linux Kernel's drivers/infiniband subsystem"
+HOMEPAGE="https://github.com/linux-rdma/rdma-core"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/linux-rdma/rdma-core"
+else
+ SRC_URI="https://github.com/linux-rdma/rdma-core/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="|| ( GPL-2 ( CC0-1.0 MIT BSD BSD-with-attribution ) )"
+SLOT="0"
+IUSE="neigh python static-libs systemd valgrind"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+COMMON_DEPEND="
+ virtual/libudev:=
+ neigh? ( dev-libs/libnl:3 )
+ systemd? ( sys-apps/systemd:= )
+ valgrind? ( dev-util/valgrind )
+ python? ( ${PYTHON_DEPS} )"
+
+DEPEND="${COMMON_DEPEND}
+ python? ( dev-python/cython[${PYTHON_USEDEP}] )"
+
+RDEPEND="${COMMON_DEPEND}
+ !sys-fabric/libibverbs
+ !sys-fabric/librdmacm
+ !sys-fabric/libibumad
+ !sys-fabric/ibacm
+ !sys-fabric/libibmad
+ !sys-fabric/srptools
+ !sys-fabric/infinipath-psm
+ !sys-fabric/libcxgb3
+ !sys-fabric/libcxgb4
+ !sys-fabric/libmthca
+ !sys-fabric/libmlx4
+ !sys-fabric/libmlx5
+ !sys-fabric/libocrdma
+ !sys-fabric/libnes"
+
+BDEPEND="virtual/pkgconfig"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc
+ -DCMAKE_INSTALL_FULL_RUNDIR=/run
+ -DCMAKE_INSTALL_UDEV_RULESDIR="$(get_udevdir)"/rules.d
+ -DCMAKE_INSTALL_SYSTEMD_SERVICEDIR="$(systemd_get_systemunitdir)"
+ -DCMAKE_DISABLE_FIND_PACKAGE_pandoc=yes
+ $(ver_test -ge 25 && echo -DCMAKE_DISABLE_FIND_PACKAGE_rst2man=yes)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Systemd="$(usex systemd no yes)"
+ -DENABLE_VALGRIND="$(usex valgrind)"
+ -DENABLE_RESOLVE_NEIGH="$(usex neigh)"
+ -DENABLE_STATIC="$(usex static-libs)"
+ )
+
+ if use python; then
+ mycmakeargs+=( -DNO_PYVERBS=OFF )
+ else
+ mycmakeargs+=( -DNO_PYVERBS=ON )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ udev_dorules "${D}"/etc/udev/rules.d/70-persistent-ipoib.rules
+ rm -r "${D}"/etc/{udev,init.d} || die
+
+ newinitd "${FILESDIR}"/ibacm.init ibacm
+ newinitd "${FILESDIR}"/iwpmd.init iwpmd
+ newinitd "${FILESDIR}"/srpd.init srpd
+}