summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-10-20 12:45:50 +0200
committerPacho Ramos <pacho@gentoo.org>2018-10-20 13:38:56 +0200
commit9b9835f15ae2c2c444069c4502fea5ad6f08912a (patch)
tree2d9f391b6aff5179644d0cf53781cf10124b86f6
parentapp-pda/pilot-link: Upstream dead, doesn't build with USE -readline (diff)
downloadgentoo-9b9835f15ae2c2c444069c4502fea5ad6f08912a.tar.gz
gentoo-9b9835f15ae2c2c444069c4502fea5ad6f08912a.tar.bz2
gentoo-9b9835f15ae2c2c444069c4502fea5ad6f08912a.zip
net-misc/sitecopy: Update sources and ebuild
Closes: https://bugs.gentoo.org/628664 Signed-off-by: Pacho Ramos <pacho@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--net-misc/sitecopy/sitecopy-0.16.6-r1.ebuild77
1 files changed, 26 insertions, 51 deletions
diff --git a/net-misc/sitecopy/sitecopy-0.16.6-r1.ebuild b/net-misc/sitecopy/sitecopy-0.16.6-r1.ebuild
index 90a94c1f611d..94aa7118251e 100644
--- a/net-misc/sitecopy/sitecopy-0.16.6-r1.ebuild
+++ b/net-misc/sitecopy/sitecopy-0.16.6-r1.ebuild
@@ -1,87 +1,62 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit autotools eutils
+EAPI=7
+inherit autotools
-DESCRIPTION="Maintain remote web sites with ease"
-SRC_URI="http://www.manyfish.co.uk/sitecopy/${P}.tar.gz
- https://dev.gentoo.org/~idella4/sitecopy-0.16.6-04-manpages-addition-fixes.patch"
HOMEPAGE=" http://www.manyfish.co.uk/sitecopy/"
-# Removed all Debian related stuff. If you want more patches, they can be ported from
-# http://ftp.debian.org/debian/pool/main/s/sitecopy/
-# The sitecopy_0.16.6-5.debian.tar.gz contains their build scripts and patches.
-# This SiteCopy now builds using the original sources.
+SRC_URI="mirror://gentoo/${P}.tar.gz
+ https://dev.gentoo.org/~jstein/files/sitecopy-0.16.6-04-manpages-addition-fixes.patch"
+DESCRIPTION="Maintain remote web sites with ease"
KEYWORDS="amd64 x86"
LICENSE="GPL-2"
SLOT="0"
IUSE="expat nls rsh ssl webdav xml zlib"
-# TODO: Depends copied over from old ebuild file, ensure they're still correct!
-DEPEND="rsh? ( net-misc/netkit-rsh )
+RDEPEND="
+ rsh? ( net-misc/netkit-rsh )
>=net-libs/neon-0.24.6[zlib?,ssl?,expat?]
<=net-libs/neon-0.30.9999[zlib?,ssl?,expat?]
- xml? ( >=net-libs/neon-0.24.6[-expat] )"
-RDEPEND="${DEPEND}"
+ xml? ( >=net-libs/neon-0.24.6[-expat] )
+"
+DEPEND="${RDEPEND}"
src_prepare() {
- # NOTE: Insert patches here.
+ default
+
# SiteCopy patches are being currently pulled & ported from
# http://ftp.debian.org/debian/pool/main/s/sitecopy/
# Consider SiteCopy to be more or less being actively maintained by
# Debian maintainers, but GPL patches ported into Gentoo.
- # NOTE: epatch is provided by 'inherit eutils'
- # Patch File Naming Format
- # files/package_name - package_version - patch_order - patch_description
-
- epatch "${FILESDIR}/sitecopy-0.16.6-01-remote-dynamic-rc.patch" \
- "${FILESDIR}/sitecopy-0.16.6-02-french-po-fix.patch" \
- "${FILESDIR}/sitecopy-0.16.6-03-wrong-memory-397155.patch" \
- "${FILESDIR}/sitecopy-0.16.6-06-sftpdriver.c-fix-for-new-openssh.patch" \
- "${FILESDIR}/sitecopy-0.16.6-10-bts410703-preserve-storage-files-sigint.patch" \
- "${FILESDIR}/sitecopy-0.16.6-20-bts549721-add-compatibility-for-neon-0.29.0.patch" \
- "${FILESDIR}/sitecopy-0.16.6-30-bts320586-manpage-document-sftp.patch" \
- "${DISTDIR}/sitecopy-0.16.6-04-manpages-addition-fixes.patch"
+ eapply \
+ "${FILESDIR}/sitecopy-0.16.6-01-remote-dynamic-rc.patch" \
+ "${FILESDIR}/sitecopy-0.16.6-02-french-po-fix.patch" \
+ "${FILESDIR}/sitecopy-0.16.6-03-wrong-memory-397155.patch" \
+ "${FILESDIR}/sitecopy-0.16.6-06-sftpdriver.c-fix-for-new-openssh.patch" \
+ "${FILESDIR}/sitecopy-0.16.6-10-bts410703-preserve-storage-files-sigint.patch" \
+ "${FILESDIR}/sitecopy-0.16.6-20-bts549721-add-compatibility-for-neon-0.29.0.patch" \
+ "${FILESDIR}/sitecopy-0.16.6-30-bts320586-manpage-document-sftp.patch" \
+ "${DISTDIR}/sitecopy-0.16.6-04-manpages-addition-fixes.patch"
# Source package uses incorrect '/usr/doc' for the doc folder. So use
# sed to correct this error.
sed -i -e "s:docdir \= .*:docdir \= \$\(prefix\)\/share/doc\/${PF}:" \
Makefile.in || die "Documentation directory patching failed"
- # NOTE: eautoconf/eautomake is provided by 'inherit autotools'
- # Need to recreate the source package provided configure script,
- # because the package provided configure script only supports
- # <neon-0.30.0 support. A patch above patches the configure.in
- # providing neon-0.30.0 support, and we then recreate the configure
- # script based upon configure.in using autotools.
-
- # First move configure.in to configure.ac, required by newer >autoconf-2.13
- # per Bug #426262 automake-1.14 compatibility
- # Should check first, autoconf-2.13 is still in the tree requiring configure.in!
- # mv configure.in configure.ac || die
-
+ mv configure.in configure.ac || die
eautoconf
eautomake
}
src_configure() {
- # TODO: USE functions copied over from old ebuild file, ensure they're still correct!
- econf $(use_with ssl ssl openssl) \
+ econf \
+ $(use_with ssl ssl openssl) \
$(use_enable webdav) \
$(use_enable nls) \
$(use_enable rsh) \
$(use_with expat) \
$(use_with xml libxml2 ) \
- --with-neon \
- || die "econf failed"
-}
-
-src_compile() {
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ --with-neon
}