summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-09-12 12:04:08 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-12 12:04:08 -0400
commit9b9dad240c7010739b592ecff43d3ce7b9fe7109 (patch)
treef86c1ecac8682cfa5351938d0ccd9b6434217866
parentgames-emulation/pcsx2: drop 1.7.4795 (diff)
downloadgentoo-9b9dad240c7010739b592ecff43d3ce7b9fe7109.tar.gz
gentoo-9b9dad240c7010739b592ecff43d3ce7b9fe7109.tar.bz2
gentoo-9b9dad240c7010739b592ecff43d3ce7b9fe7109.zip
games-emulation/pcsx2_patches: drop 0_p20230722
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--games-emulation/pcsx2_patches/Manifest1
-rw-r--r--games-emulation/pcsx2_patches/pcsx2_patches-0_p20230722.ebuild54
2 files changed, 0 insertions, 55 deletions
diff --git a/games-emulation/pcsx2_patches/Manifest b/games-emulation/pcsx2_patches/Manifest
index 2a3c5af71610..cfb4281bd4c5 100644
--- a/games-emulation/pcsx2_patches/Manifest
+++ b/games-emulation/pcsx2_patches/Manifest
@@ -1,2 +1 @@
-DIST pcsx2_patches-0_p20230722.tar.gz 605026 BLAKE2B 47bc0d7676d50f5e1ec60cc473e9290070996e8159260a35a2aaabb771bc7341d248050cb5e13bb72d857709abf522f5c48a1b5a1b9f6ccbaae2c014c2511fbf SHA512 d31863829d47b77d23479e1c498990719cbfb1ddbf25786a0be9f2c2540b9c7f24f080815f4fc37ee710d4d0b75c4d9eb1dabc82564b0d092aeebab6010dc851
DIST pcsx2_patches-0_p20230822.tar.gz 618444 BLAKE2B a51bba04e4bd52f8d04e5529ce05c7d22cd550bd00a5268b29addba24ca45f9c248ba9a7012a54e0187dfd75c423748b09e3afdafdd421177e8b08cbfd4809e4 SHA512 8a8ae2ed4a4b5ebca9f8a9d0b12d6fb9c862bc68496f167dc02fac4c1b39767a9bd9ff84373e43484b7a06693b06f07f2e9b283d3ec3de0202807f46801ce190
diff --git a/games-emulation/pcsx2_patches/pcsx2_patches-0_p20230722.ebuild b/games-emulation/pcsx2_patches/pcsx2_patches-0_p20230722.ebuild
deleted file mode 100644
index 0bd2dd95b845..000000000000
--- a/games-emulation/pcsx2_patches/pcsx2_patches-0_p20230722.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-inherit python-any-r1
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/PCSX2/pcsx2_patches.git"
-else
- HASH_PCSX2_PATCHES=0493be5016c74373465c9d3b67bbdcdd12adb100
- SRC_URI="
- https://github.com/PCSX2/pcsx2_patches/archive/${HASH_PCSX2_PATCHES}.tar.gz
- -> ${P}.tar.gz"
- S=${WORKDIR}/${PN}-${HASH_PCSX2_PATCHES}
- KEYWORDS="~amd64"
-fi
-
-DESCRIPTION="Collection of game patches for use with PCSX2 (e.g. widescreen hacks)"
-HOMEPAGE="https://github.com/PCSX2/pcsx2_patches/"
-
-# these are normally distributed by upstream with PCSX2 which is GPL-3+
-LICENSE="GPL-3+"
-SLOT="0"
-
-BDEPEND="${PYTHON_DEPS}"
-
-src_compile() {
- # upstream uses a constantly replaced "latest" patches.zip (currently no
- # real releases), and github's .zip archives cannot be used either due to
- # having the patches/ subdirectory -- so we use a snapshot and repack
- # (could use app-arch/zip, but python is more likely to skip a dependency)
- ebegin "Creating patches.zip"
- "${PYTHON}" - <<-EOF
- import pathlib
- from zipfile import ZipFile, ZIP_DEFLATED
-
- patches = pathlib.Path("patches/")
-
- with ZipFile("patches.zip", "w", ZIP_DEFLATED, compresslevel=9) as archive:
- for file in patches.iterdir():
- archive.write(file, arcname=file.name)
- EOF
- eend ${?} || die
-}
-
-src_install() {
- insinto /usr/share/pcsx2/resources
- doins patches.zip
-
- einstalldocs
-}